NextPit To the NextPit homepage

How to install Android 5.0 Lollipop on a Nexus 5

How to install Android 5.0 Lollipop on a Nexus 5

The time is now! If you've been waiting for Android 5.0 Lollipop to launch, it is now available as an over the air update. It can take a while for OTA updates to hit phones and tablets, and if you want to get the latest version of Android on your Nexus 5 right now, here's how you can grab yourself a copy of the factory image and install Lollipop for yourself.

Android lollipop nexus 1
Want Android 5.0 Lollipop on your Nexus 5 right now? Manually upgrade! / © ANDROIDPIT

Warning: Before you start this process you should be aware that install a factory image will wipe out all of the data on your Nexus 5. As such, make sure that you have backed up everything you do not want to lose so you can restore it when the installation completes.

Prerequisites

You need a few things to start with:

Then extract the downloaded files on your computer. 

Unlock bootloader

If you have already unlocked the bootloader of your Nexus 5 then you can skip this step, but if not, here's how to do it:

  • Turn off your Nexus 5.
  • Press and hold Volume Down and Power to enter the Fastboot menu.
  • Connect the Nexus 5 to your computer via USB cable.
  • Go into the adb-tools folder and hold the Shift key on your keyboard then click the right mouse button on any free area of white space in the Windows Explorer window. Select ''Open Command Window Here'' with your left mouse button.
  • Once the command window is open, enter the following command to unlock the bootloader:

fastboot oem unlock

  • Press the Volume Up button on the Nexus 5 to accept the command and press the Power button to confirm. The bootloader will now be unlocked, and all data will be lost.

Install Factory Image

  • Get your Nexus 5 into Fastboot by turning it off and pressing Volume Down and Power until Fastboot appears.
nexus 5 fastboot
Flick your Nexus 5 into Fastboot to install Android 5.0 Lollipop. © ANDROIDPIT
  • Connect the Nexus 5 to your computer with a USB cable. 
  • On your computer, navigate to the unpacked directory that contains the factory image for your device. 
  • Double click the flash-all.bat file and wait until the installation is finished. Your Nexus will reboot itself after completion.

Troubleshooting

If your Nexus 5 gets stuck in a bootloop at the Google logo on startup, do the following:

  • Disconnect your Nexus from your computer and turn it off.
  • Press and hold the Volume Down and Power button to enter Fastboot.
nexus 5 recovery fastboot w
If you get into trouble, Recovery Mode is on hand to help. © ANDROIDPIT
  • Use the volume buttons to highlight Recovery Mode and press Power to confirm
  • If you have a custom recovery like CWM you'll enter it immediately. If you see the Android laying on its back just press the Power button and Volume Up button briefly to enter stock Recovery.
  • In the recovery menu, use the volume buttons to highlight wipe cache partition and press Power to confirm.
  • Scroll down to wipe data/factory reset and press Power to confirm. Reconfirm your seelction and let your Nexus reset.
  • If your Nexus doesn't reboot automatically you can select reboot sytem now from the menu and hit Power to confirm.

That's it, you're done. Your Nexus should now boot successfully. The very first boot process takes several minutes by the way, so do not be surprised if it takes longer than what seems usual.

So... have you manually upgraded to Android 5.0 Lollipop?

Liked this article? Share now!
Join the discussion

81 comments

Write new comment:
All changes will be saved. No drafts are saved when editing
Write new comment:
All changes will be saved. No drafts are saved when editing

  • Mark Dee Nov 30, 2014 Link to comment

    I'm getting the "archive does not contain ..." messages that others have mentioned but things seem to proceed OK until I get a malloc error.

    erasing 'userdata'...
    OKAY [ 7.703s]
    formatting 'userdata' partition...
    Creating filesystem with parameters:
    Size: 13725835264
    Block size: 4096
    Blocks per group: 32768
    Inodes per group: 8144
    Inode size: 256
    Journal blocks: 32768
    Label:
    Blocks: 3351034
    Block groups: 103
    Reserved block group size: 823
    Created filesystem with 11/838832 inodes and 93654/3351034 blocks
    malloc: Permission denied
    Cannot generate image.
    FAILED ()
    finished. total time: 241.266s

    Thoughts? Thanks.


    • Mark Dee Nov 30, 2014 Link to comment

      Worked around it by extracting cache.img and userdata.img and manually flashboot'ing them. Lollipop is running for me. Thanks for putting together the page.


  • Mohammad Arif Nov 27, 2014 Link to comment

    Hello, i did exactly everything you wrote and it worked perfectly fine, although i faced few issues earlier..
    I have one question to ask you.
    now that i have flashed my nexus 4 to kitkat 4.4.4., it had again started to give me notifications about system update to 5.0, which i am unable to disable, nor can i find the google services framework in : Setting>apps>google services.

    how can i disable that particular notification, as its very annoying.

    Thanks


  • Patryk Banaś Nov 24, 2014 Link to comment

    Hello. I have a little problem. I used a Nexus root toolkit to install it to my Nexus 32 Gb model. And with this 32 Gb apper the problem. Now i have only 12 free space....but should be 29... Someone can help ?


  • Tara Taqa Nov 22, 2014 Link to comment

    ROADBLOCK: I was getting an error, but fixed it by scrapping your bat file and googling "missing system.img error". Did it one line at a time and now everything works great!

    www.ibtimes.co.uk/how-fix-error-update-package--android-5-0-factory-images-nexus-devices-1474865


  • Geordy ior Nov 19, 2014 Link to comment

    What if I get stuck at the Google logo and I don't have any custom recovery like CWM. How do I wipe the cache ? Tx


  • Vinicius Nov 18, 2014 Link to comment

    I can't understand the "Unlock bootloader" step:

    - "Press the Volume Up button on the Nexus 5 to accept the command and press the Power button to confirm. The bootloader will now be unlocked, and all data will be lost."

    Until when should I press the Volume Up button to accept the command? Or which option should I press the Power button? Thx in advance.


    • Vinicius Nov 18, 2014 Link to comment

      Because I pressed it at the Start option and it just restarted the OS and my all my data was still on place.


    • Vinicius Nov 18, 2014 Link to comment

      Ah forget it, it just started to update by itself :)


  • Angel Torres Nov 17, 2014 Link to comment

    Also I can't extract the factory image file it says the file is broken.


  • Angel Torres Nov 17, 2014 Link to comment

    I need help, this flash.all bat file doesn't appear on my laptop I can't do anything I already unlocked my phone's bootloader and everything.


  • deepak cano Nov 16, 2014 Link to comment

    gets stuck at fast boot mode. are there any videos where i can refer?


  • Abdulrahman Rmaileh Nov 16, 2014 Link to comment

    I have nexus 5... But still didn't get it.
    When I press check now for the update it does nothing! It keeps telling last checked 1-1-1970... Is that a problem?


  • Rob Maria Nov 16, 2014 Link to comment

    Anyone having trouble installing after downloading and successfully getting your phone connected to ADB, follow these instructions. After you download and extract all the ADB files and Image files, you need to copy and paste all the files from the extracted image folder in to the same folder that contains the ADB and Fastboot files, then run flash-all.bat. This is important, and should be clarified here. When you run the flash-all.bat file, the code calls on the fastboot and other executables, which push the .img files to the device. If the files are not directly present in the same directory, the batch file cant see them.


  • Yaseer Nov 15, 2014 Link to comment

    How To Directly Download Apk On Your Phone & Computer
    Check Out Here - goo.gl/wTMExy


  • Aditya Wicaksono Nov 15, 2014 Link to comment

    i have problem here, after fastboot oem unlock. i try flash-all.bat, but the fastboot not recognized internal and external. please help


  • Jens Clarberg Nov 15, 2014 Link to comment

    Yep, it's worked now just by cheer luck. I didn't do anything differently to the previous times but hey! Thanks for your help.


    • Void Nov 15, 2014 Link to comment

      no problem, glad it worked this time =)


  • Void Nov 15, 2014 Link to comment

    that's what I saw before it went to the swirling colors and about 3-5ish minutes later it worked


  • Jens Clarberg Nov 15, 2014 Link to comment

    After executing the flash-all.bat file my phone just stays on the flying colourful dots.. I have tried going in to recovery mode and wiping data, and trying again but it doesnt get further than this. Help!


    • Void Nov 15, 2014 Link to comment

      how long did you wait before restarting the phone? In my experience the first boot takes a few minutes before it gets past the swirling dots


      • Jens Clarberg Nov 15, 2014 Link to comment

        I'm going to go with 35 minutes.


      • Void Nov 15, 2014 Link to comment

        ouch... you can try to restart the phone in the bootloader and flash each image manually... that's what I did and it worked for me


      • Jens Clarberg Nov 15, 2014 Link to comment

        That's what I did the first 2 times..


      • Void Nov 15, 2014 Link to comment

        did you restart the bootloader after flashing the bootloader and the radio images?


      • Jens Clarberg Nov 15, 2014 Link to comment

        Yes I did. I literally don't know what else I can do, the amount of problems I've had with this phone...


      • Jens Clarberg Nov 15, 2014 Link to comment

        Now I tried with that method again and I'm getting a different animaton (the 'working' robot) maybe its about to work? I didn't see this before the boot animation before.


  • Ionut Nov 14, 2014 Link to comment

    FOR THE "MISSING RECOVERY, SYSTEM , BOOT.IMG" ISSUE. go to this website: androidpolice.com/2014/11/12/running-into-the-dreaded-missing-system-img-error-flashing-android-5-0-factory-images-heres-how-to-get-around-it with www in front....


  • Hung Nov 14, 2014 Link to comment

    I'd followed exactly this guide
    www.youtube.com/watch?v=5ka5dnPghzI
    and my nx5 gets L well.


  • Jesse Nov 14, 2014 Link to comment

    everything goes well, but then the prompt says 'not enough space' 'cannot generate image' 'FAILED', I wiped my phone so there should be enough space.... how do i solve this?


  • Colin Stulp Nov 14, 2014 Link to comment

    hi, mine says i have an error and can't load in to bootloader. there is no such file or directory, press any key to exit... Can someone help me?


    • MarcosGanon Nov 14, 2014 Link to comment

      Try updating the drivers using the steps someone described above.


  • Void Nov 14, 2014 Link to comment

    has anyone found the solution to the error
    "archive does not contain 'boot.sig'
    archive does not contain 'recovery.sig'
    failed to allocate 1005154516 bytes
    error: update package missing system.img
    Press any key to exit..."

    I'm stuck at this point and I see the system.img file in the directory, it just doesn't want to read it.


    • MarcosGanon Nov 14, 2014 Link to comment

      Erase the cache and data in recovery (see troubleshoot steps). I was stuck here too and that worked.


      • Void Nov 14, 2014 Link to comment

        Tried it, same error. thanks for the idea though


      • MarcosGanon Nov 14, 2014 Link to comment

        Hmmmm. Try the trick where you put all the unzipped items in the adb_tools folder. I didn't add that part to my suggestion.


      • Void Nov 14, 2014 Link to comment

        Tried that one too, got the same result =/


      • Void Nov 15, 2014 Link to comment

        figured it out. had to flash ass of the image files individually and then wipe the data from the phone


  • Dusan V. Nov 13, 2014 Link to comment

    I did manual update by following your instruction and everything was done in 6 minutes. Thank you guys! Done on windows 8.1 and nexus 5


  • Ionut Nov 13, 2014 Link to comment

    Hey, stupid question , but want to be sure. If i update manually, will i get notification for updates in the future? for example let's say a 5.1 version will be available...And is this the official 5.0? thank you in advance!


  • Pankaj Sharma Nov 13, 2014 Link to comment

    Stuck at animation logo, did all Wipe data reset but it still stuck at animations what to do ?


  • Prakash Dumbre Nov 13, 2014 Link to comment

    Okay ! I followed everything - My device just stuck on screen written google and tiny lock at the bottom. And its been like 15 min.

    Need help please !!


  • Jørgen Sivertsen Nov 13, 2014 Link to comment

    I have cataclysm installed, is the procedure different if I want to install the stock ROM?


  • Pedro Almeida Nov 13, 2014 Link to comment

    Guys, I unlocked the bootloader, but when i try to execute the flash-all.bat appears the following error " 'fastboot' is not a recognized as an internal or external command, operable program or batch file. Press any key to exit..." any help?


    • Mark Wilson Nov 13, 2014 Link to comment

      Make sure that you have Fastboot and ADB in the same folder as your unzipped image.


    • Timothy Lam Nov 13, 2014 Link to comment

      you need to use Windows 7, Windows 8.1 is not working


  • Chaitanya Reddy Nov 13, 2014 Link to comment

    can u guys post a video on how to install 5.0 on a nexus 5
    it will be very helpful!!!!!


  • amith pujari Nov 13, 2014 Link to comment

    finally...


  • andrew bradt Nov 13, 2014 Link to comment

    Nice tutorial but what do I need to do since I am on a mac?


  • Joseph Beltran Nov 13, 2014 Link to comment

    i have the next problema
    "archive does not contain 'boot.sig'
    archive does not contain 'recovery.sig'
    failed to allocate 1005154516 bytes
    error: update package missing system.img
    Press any key to exit..."


    • Danilo Aguillar Nov 13, 2014 Link to comment

      Same thing here... Already tried to unzip the file image-hammerhead-lrx21o.zip and nothing, and I tried to edit the file flash-all.bat (I saw that there's no space between image-hammerhead-lrx21o.zip and "echo", so I put the space), and nothing too...

      Anyone?


      • Joseph Beltran Nov 13, 2014 Link to comment

        Yes... i have the same problem


      • Joseph Beltran Nov 13, 2014 Link to comment

        I have the solution... In the zip "adb-tools_treiber" go to "adb-treiber" and execute the "UniversalAdbDriverSetup", after the installation change the port USB and execute "flash-all".


      • Danilo Aguillar Nov 13, 2014 Link to comment

        Still the same problem here :(.


      • Joseph Beltran Nov 13, 2014 Link to comment

        I have the solution... In the zip "adb-tools_treiber" go to "adb-treiber" and execute the "UniversalAdbDriverSetup", after the installation change the port USB and execute "flash-all".


      • F L 4 T Nov 13, 2014 Link to comment

        Hey, solution here:
        copy the files inside (use winrar to extract f.ex ) the factory image to the "adb tools" folder where you previously unlocked your bootloader and execute the "flash-all" bat file from there and it will work.
        Let me now if it worked for you guys.
        Cheers.


      • Dzulsallehhuddin Mohd Zol Nov 13, 2014 Link to comment

        still the same..


      • Akash Parapoyil Nov 13, 2014 Link to comment

        This works. Thanks Yo


  • Mark Wilson Nov 13, 2014 Link to comment

    Done, and looks great! Thanks Mark Wilson!


  • Lukas Kuhn Nov 13, 2014 Link to comment

    when i try to execute the flash-all script a window pops up and says that fastboot either wasnt written right or wasnt found... i already unlocked the bootloader what should i do now ?


    •   1
      Deactivated Account Nov 19, 2014 Link to comment

      - Rob Maria

      "After you download and extract all the ADB files and Image files, you need to copy and paste all the files from the extracted image folder to the folder that contains the ADB and Fastboot files, then run flash-all.bat."


  • Kris Carlon Nov 13, 2014 Link to comment

    Call me crazy, but having the final version on my Nexus 5 has me sooo much more excited than all the developer previews over the last few months. Let's hope it's not as laggy as it has been on the Nexus 9.


  • Daniel Su Nov 13, 2014 Link to comment

    I'm very confused on the directory part


    • Mark Wilson Nov 13, 2014 Link to comment

      What are you having trouble with? Once you have extracted the contents of the downloaded file, just look for the flash-all.bat file in the folder that has been created.


      • Daniel Su Nov 13, 2014 Link to comment

        Oh Ok that makes sense thanks


      • Mark Wilson Nov 13, 2014 Link to comment

        Cool! Let us know how things go!


      • Daniel Su Nov 13, 2014 Link to comment

        Hey, I'm still trying to open the factory image, on my Surface Pro, it's just a blank file with a .TAR file


      • Lukas Kuhn Nov 13, 2014 Link to comment

        when i try to execute the flash-all script a window pops up and says that fastboot either wasnt written right or wasnt found... i already unlocked the bootloader what should i do now ?


      • Lukas Kuhn Nov 13, 2014 Link to comment

        when i try to execute the flash-all script a window pops up and says that fastboot either wasnt written right or wasnt found... i already unlocked the bootloader what should i do now ? my device is in fastboot mode an connected


      • andrew bradt Nov 13, 2014 Link to comment

        Hello, I am on a mac and am very confused on how to install L onto my phone. I have no idea what happened as well and my clear cache froze and now says: failed to mount. I am currently formatting the data and the blue bar does not seem to be moving. I am stumped.. Any help would be greatly appreciated.


      • Sumit Jain Nov 13, 2014 Link to comment

        while running the flash-all.bat the error message is showing as 'fastboot' is not recognised as an internal or external command, operable program or batch file.


      • Joakim Brovoll Nov 13, 2014 Link to comment

        When I try to extract the hammerhead zip, it says one file is broken.. what is up with that?


      • Jey Bala Nov 14, 2014 Link to comment

        There are 2 zips that we downloaded, the ADB tools and the factory image. In which directory among these two zips, can we find the flash all batch file. Because I see only one file being extracted from factory image and adb tools zip has only fastboot files

        The tar file is extracting only one file, Am I doing something wrong here or is the download itself is incorrect


      • Rob Maria Nov 16, 2014 Link to comment

        After you download and extract all the ADB files and Image files, you need to copy and paste all the files from the extracted image folder to the folder that contains the ADB and Fastboot files, then run flash-all.bat. This should be clarified here.


      •   1
        Deactivated Account Nov 19, 2014 Link to comment

        I made an account on here just to thank you. This is blatantly an important step that should have been mentioned in the article.


      • Christian Plovst Nov 20, 2014 Link to comment

        Thanks dude! I had trouble doing this part till i saw your comment (Y)


  • Leonardo Nov 12, 2014 Link to comment

    Whoopeee perfect birthday gift!!! getting it right now!


  • Harish Nov 12, 2014 Link to comment

    Can you upload the ota file for adb sideload?

Write new comment:
All changes will be saved. No drafts are saved when editing