Problem with REQUEST_INSTALL_PACKAGES, in Android

  • Replies:1
  • Forum posts: 1

Oct 20, 2022, 12:36:44 PM via Website

For about two weeks we have had the problem that Google / Android are rejecting apps for updates with the following statement:

We found that your app is not compliant with how REQUEST_INSTALL_PACKAGES permission is allowed to be used. Specifically, the use of the permission is not directly related to the core purpose of the app.

Indeed, some of our apps had included this right in the past, but recent updates (for more than 6 months) no longer. We have checked and confirmed the current status as follows:

Manifest controlled
Searched all APK and plugins
APK details in the store does not show this right either
Display of the affected APK using "Sensitive Rights": all old beta versions which are not active
Unfortunately, all our objections and general support requests (also via other Google areas) are consistently ignored.

It is impossible for us to update our apps. Which is extra critical, especially with regard to requirements regarding newer SDK and billing API in two weeks.

How can we obtain help with the issue?

We're not a very small publisher, it's about apps with several hundred thousand installations.

Reply
  • Forum posts: 1,518

Oct 21, 2022, 11:03:30 AM via Website

If you are sure that your app does not require REQUEST_ INSTALL_ PACKAGES permission, maybe you can only contact Google customer service for help through the Google Play Developer Console.

Download size < 0.15 MB. But also Accurate enough, Ad-free & Pure.
The minimalist app is available on Google Play https://goo.gl/ws42fN
Your 5-star is appreciated. Blog: https://okblackcafe.blogspot.com

Helpful?
Reply