Samsung Galaxy S3 — Possible phone bricking. Stuck on Samsung splash screen!

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Nov 5, 2016, 1:21:34 AM via Website

Hi all. About 3 years ago I got a new S3 phone from my carrier under contract and after the contract was over I decided to root my phone. The phone has deteriorated over time and the USB doesn't work neither does the sound but I still used it. 2 days ago I pickup my phone and noticed all of my primary apps from the Play Store has disappeared. I thought this was really strange because when I go into the application manager I see that everything is still running but it's a 0.00 bytes. So I restart my phone and nothing happens and there are still no apps. The Play Store icon has disappeared as well and so I found my phone has finally messed up. So I try and clear the cache partition but still no go everything is still missing. Then I thought why not might as well start it new and so I factory reset my phone. But now it's stuck at the Samsung splash screen and won't go any further. Is there a way that I can possibly fix this? I do have a microSD card so I was thinking I can load up a fix for it in the micro SD card and Boot It Up from there because there's no way I can connect my phone to the PC has my USB is broken. I'm just not sure what files I need to download or if it's even possible. If anyone can help me that would be greatly appreciated. Thank you

I've got a Samsung Galaxy S3 GT-I9305

  • Forum posts: 3

Nov 5, 2016, 3:42:53 PM via Website

Do you have a custom recovery installed ? If so which recovery?

Recommended articles