Samsung Galaxy S3 stuck on boot logo (flashing logo) HELP!!!

  • Replies:3
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Oct 11, 2016, 5:01:15 PM via Website

Hey people
Im gonna try and be plain with this but ive just found my samsung galaxy s3. Ive tried turning it on to see any old pictures that may still be on it but when i turned it on the samsung logo came up but after around 3 seconds it goes away and comes back as of its constantly rebooting.
Is there a fix i myself can do without taking it to a shop?
Ive tried clearing cache partition and user data but the problem is still ongoing
help would be much appreciated.
Blake :D

  • Forum posts: 39

Oct 12, 2016, 1:14:12 AM via Website

I'm sure the operating system got corrupted, Can you able to connect it with your laptop or desktop using the cable?

  • Forum posts: 12

Jul 23, 2017, 7:58:20 PM via Website

Here’s what you need to do to fix this issue without losing the data on your phone. Try a battery pull first. Take out the phone battery (and the micro SD card if you have one installed) then press and hold the power button for at least a minute. Reinsert the battery (leave the micro SD out) then try to turn on your phone.
If your phone is still stuck on the Samsung logo then proceed with wiping the cache partition of your phone.

  • Forum posts: 1

Jul 23, 2017, 9:43:19 PM via Website

image I have the very same problem. Even after resetting my Samsung Galaxy S2 to the factory settings and rebooting it several times it still can't go past the Samsung logo. What other options do we have to fix this problem?

Recommended articles