Samsung Galaxy S3 white screen + no PIT partition

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jun 21, 2016, 2:51:08 PM via Website

I'm trying to fix a Galaxy S3 and my main problem is this:
(paste it in your adress bar)

I think that it's a hardware issue but in the past few hours I've been trying to
flash the stock rom. Unfortunately I haven't had any luck because I get an error from Odin "There is no PIT partition".
(paste it in your adress bar)

Here's what I tried:

-Odin 3.04, 3.07, 3.09 and 3.11.1
-4 different USB cables which I plugged into a USB 2.0 port on the back of my motherboard
-reinstalled the Samsung USB drivers
-tried to flash on 2 PCs
-tried to update via KIES but gets stuck on 0% while updating

KIES is not running while I'm using Odin and I paste the path to the .tar.md5 file in the PAD(for older versions) or AP(for newer versions) tab.
In both new and old versions Auto Reboot and F. Reset Time are checked and everything else is unchecked.
It doesn't seem that I can get into the recovery or get the phone to boot normally because of the white screen with gray lines but I can get into downloading mode and it shows this:

-Product name: GT-I9300
-Custom binary download: No
-Current binary: Samsung official
-System status: Custom

If it's a hardware issue then I know that there is no way to fix it. I still think that something can be done and I hope you guys can give me some advice. Thank you.

  • Admin
  • Forum posts: 859

Jun 21, 2016, 5:52:44 PM via Website

This is a hardware issue, you have to sent it to Samsung service center.

— modified on Jun 24, 2016, 4:39:47 AM

Ready To Help You.


Recommended by NextPit