Sony Ericsson Xperia Arc S — Google play store doesn't open ??

  • Replies:9
  • OpenNot stickiedUnanswered
  • Forum posts: 5

Aug 25, 2012, 4:53:12 AM via Website

Hi everyone,,

Google play store doesn't open on my Xperia and gives me a message '' connection timed out ''.

I have Gmail account , updated version and good internet connection but still doesn't open and gives me the same message.

Sony Xperia contact center told me to perform a Factory data reset in the phone, I followed the instructions but the problem still exist.

any one can help me .... my phone still new and I want to install applications on it.

  • Forum posts: 5

Aug 27, 2012, 2:47:36 PM via Website

No one can help me ????:(

  • Forum posts: 610

Sep 20, 2012, 6:38:59 PM via Website

If you're still having problems, goto settings, apps, all; select play store and clear data.


  • Forum posts: 5

Sep 22, 2012, 1:12:34 PM via Website

Thanks ,, I solved the problem by modifying some settings on network

  • Forum posts: 1

Sep 23, 2012, 2:40:05 AM via Website

Bro, I'm havin the same problem. Can you please guide me as to how you solved it? Thanks alot.

  • Forum posts: 5

Sep 24, 2012, 12:55:17 AM via Website

Instead of connecting with wireless Internet directly .... I entered the settings manually to connect with Internet through my mobile network

go to : Main menu / Settings / Wireless & Networks / Mobile networks / Access Point Names / create APNs

Once I entered the settings for my mobile network .. all the applications who need Internet start working normally.

Don't ask me how .... but this is what happen to me.

Now I am connecting with wireless Internet and I can download from Google play store.

I hope it will help you.

  • Forum posts: 1

Jan 19, 2013, 11:51:30 AM via Website

Heres what I did, go to your settings : manage apps: and go where they list all the apps. Scroll down the list and see if there are any of the Google / download apps disabled. My download manager was disabled and everytime I tried to access google play it would cut off. After enabling the download manager, i was able to download apps once again.

Hope this helps.

Salah Barzani

  • Forum posts: 13

Apr 3, 2013, 6:47:53 PM via Website

Good work man. plz also tell us how you fix this issue