Sony Xperia Z Ultra stuck on black screen

  • Replies:0
  • Forum posts: 1

Aug 10, 2016, 2:18:35 PM via Website

Ok guys so I have a Sony Xperia Z Ultra and I decided to install Marshmallow 6.0 on it (which wasn't released for my phone). I downloaded the boot, cache, system and userdata imgs of Marshmallow 6.0 and installed them using fastboot, then I was supposed to boot in recovery mode and wipe the caches and do a reset, before installing the G-apps zip file and completing the entire process. So I tried to start recovery mode which I had previously installed already and it failed, starting in safe mode instead. Then I re-installed the recovery using a batch file in a directory downloaded from NUT's XDA Developers download site, which failed on the first try. So I tried again and it was installed, meaning my phone will automatically reboot into recovery right after it was done. My phone rebooted but my screen remained black and nothing happened. I tried holding down the power button and it vibrated but nothing happened again. I tried holding down the power and volume down button for 30sec and more, tried it with the volume up button too and it didn't work. I tried connecting my phone to the pc but it won't recognize it (of course) and I tried holding the volume up button upon connecting to enter fastboot but that failed as well. Now it's stuck like this and I'm hoping its battery drains out and it powers off. Help.