• Replies:5
  • OpenNot stickiedUnanswered
  • Forum posts: 3

Feb 4, 2016, 3:56:04 PM via Website

Hey folks I got a problem here that I am not able to download or update any app in my fine I dunno why it reaches 80%then it's stop.. I tried all the methods were mentioned here even I did the factory settings it worked for a week then I suffer same problem again

  • Admin
  • Forum posts: 859

Feb 4, 2016, 6:06:02 PM via Website

Go to settings >> app manager >> then clear cache from play store and play service apps
If the problem still exist go to settings >> app manager >> choose play store >> uninstall updates
If none works, remove google account and add it back

Also don't forget to delete unwanted apps

— modified on Feb 4, 2016, 6:06:26 PM

Ready To Help You.


  • Forum posts: 3

Feb 5, 2016, 10:30:38 AM via Website

Thanks man.. I have did all of that already.. Even I did reset factory settings.. Still the same issue

  • Forum posts: 76

Feb 5, 2016, 7:27:36 PM via Website

Hey, Zest
have you tried updating google play services

OR try this

Update both google play and google play services to latest version and even if if it didn't fix clear both apps data and
also of google Service Framework
and reboot device I hope this will fix it
Tell me if it worked for u or not Good Luck :)


  • Forum posts: 3

Feb 5, 2016, 8:24:46 PM via Website

Thanks Mr Junaid... Actually after I cleared the data in Google service framework it works great.. Thanks again for ur help

Junaid Q.

Recommended by NextPit