Whatsapp notification Problem

  • Replies:52
  • OpenNot stickiedUnanswered
  • Forum posts: 3

Oct 16, 2014, 5:23:14 AM via Website

Dear Team, am not receiving whatsapp notification and new messages while my screen is locked/off. When i manually enter the whatsapp that time only i am receiving notification and messages. I checked my device completely all notifications was enabled condition only even i checked whatsapp notification settings also there also al notification was enabled only. yesterday i downloaded and installed the new version of whatsapp but still notification was not receiving. My network also good condition only i am using 2G. In the same way i am receiving wechat and gmail notification normally but whatsapp only am not receiving the notifiication. Kindly help me to solve this.

Reply
Lalit
  • Admin
  • Forum posts: 2,323

Oct 16, 2014, 7:35:59 AM via Website

Well, @Pradheep that's weird, :? anyway look if turned the sync option enabled, and if that still doesn't helps try clearing the cache and data stored stored by whatsapp. One more thing are you using any battery savers ?(lightbulb) Because I use to encounter this problem when I was using some battery savers to kill the application running over the background ! (thinking)

Ihsan Wan

Reply
  • Forum posts: 3

Oct 16, 2014, 9:14:09 AM via Website

John F.

Well, @Pradheep that's weird, :? anyway look if turned the sync option enabled, and if that still doesn't helps try clearing the cache and data stored stored by whatsapp. One more thing are you using any battery savers ?(lightbulb) Because I use to encounter this problem when I was using some battery savers to kill the application running over the background ! (thinking)

Dear John, thanks for your quote. I am checked there is no battery saver installed on my mobile and also am enabled auto sync and background data but still am facing the problem. Yesterday onwards i am facing another one more problem while opening whatsapp its automatically force-closed up to 3 to 5 times. For gmail and wechat i am getting normal notification even my screen is locked/off. But whatsapp only the problem. Kindly help me.

damponting44

Reply
Lalit
  • Admin
  • Forum posts: 2,323

Oct 16, 2014, 10:13:51 AM via Website

Okay, @Pradheep Don't panic we will try to get things working back to normal, :) Okay, no open up your device settings>application manager>tap over whatsapp and try clearing the cache and the data stored. See if that work out for you ! (angel)

Ihsan Wandamponting44

Reply
  • Forum posts: 3

Oct 17, 2014, 11:01:48 AM via Website

John F.

Okay, @Pradheep Don't panic we will try to get things working back to normal, :) Okay, no open up your device settings>application manager>tap over whatsapp and try clearing the cache and the data stored. See if that work out for you ! (angel)

Dear John, that also i did but still i am facing the problem and one more problem also i am facing whenever i open the whatsapp its automatically force-stopped.

damponting44

Reply
  • Forum posts: 1

Jan 22, 2016, 12:19:05 PM via Website

Pradheep

John F.

Okay, @Pradheep Don't panic we will try to get things working back to normal, :) Okay, no open up your device settings>application manager>tap over whatsapp and try clearing the cache and the data stored. See if that work out for you ! (angel)

Dear John, that also i did but still i am facing the problem and one more problem also i am facing whenever i open the whatsapp its automatically force-stopped.

Hello, people. This is sam even I am facing the same problem with whatsapp notification. Please help

damponting44

Reply
Deactivated Account
  • Admin
  • Forum posts: 861

Jan 23, 2016, 6:33:21 AM via Website

Disable power saver mode
Uninstall or disable apps that disables the background process
If you have any battery saver apps, disable them. Usually these apps disable background apps to gain battery power

Ready To Help You.

Ihsan Wandamponting44

Reply
  • Forum posts: 1

May 12, 2016, 8:57:06 AM via Website

Finally got a solution for the whatsapp notification problem after many months......
I am using Samsung Galaxy J7.
Friends, follow the path:
Settings->Data Usage->Select Whatsapp-> And make sure Restrict background data is unchecked.

I did the same. It worked for me.
Hope it will work for u tooooo.

suraj guptaNibin NizarIhsan Wandamponting44Appu Choudhury

Reply
  • Forum posts: 1

Jun 14, 2016, 10:39:04 AM via Website

Settings->Data Usage->Select Whatsapp-> And make sure Restrict background data is unchecked.

Yeah but if we lock the phone .. the restrict background automaticly are "checked" again.

Ihsan Wandamponting44

Reply
  • Forum posts: 2

Jun 17, 2016, 4:10:25 PM via Website

Same problem i am facing it gets checked automatically and we wont get notification.

Reply
  • Forum posts: 2

Jun 17, 2016, 4:11:08 PM via Website

But it gets checked automatically and we wont get notification.,what to do

Reply
  • Forum posts: 5

Jun 22, 2016, 6:09:50 AM via Website

Thank you Lalit, it was helpful. I thought this may be a problem with WhatsApp notification setting.

Reply
  • Forum posts: 1

Jun 26, 2016, 7:22:18 PM via Website

same issue . whatsapp web also working for 1-2 minutes , then only the phone gets notifications , and then also the phone stops to get it untill unlocked

Reply
  • Forum posts: 1

Jun 30, 2016, 11:11:58 AM via Website

Go to Application Manager->Whatsapp

You will see Notifications and may show as disabled.

Click Notifications->Allow Notifications.

This should work.

I was having a tough time from a long long time. But eureka it worked!

Ihsan WanLeen Segers

Reply
  • Forum posts: 2

Aug 12, 2016, 8:06:54 PM via Website

Im also having the same problem here.. wen we try to off the restrict data... After few min its turn on automaticly....

Aisyah Amirul

Reply
  • Forum posts: 2

Aug 12, 2016, 8:10:08 PM via Website

Wat to do... really need help... this is my 1st time im using android and face this kind of problem

Reply
  • Forum posts: 2

Aug 29, 2016, 5:52:59 AM via Website

I'm teaching the same problem with my new note 7. It worked ok for a week then I changed my sim card and reinstalled whatsapp then the problem started... Even the Samsung service centre is baffled

Reply
  • Forum posts: 2

Aug 29, 2016, 5:53:25 AM via Website

Sorry I meant to say I'm having the same problem

Reply
  • Forum posts: 2

Aug 29, 2016, 10:57:53 AM via Website

I've the same problem - I don't get any notification from WhatsApp. I am so upset on it. :( please help in solving the problem. Thanks

Reply
  • Forum posts: 2

Aug 31, 2016, 7:56:28 AM via Website

Hi All!

I'm very excited to inform you that I've got the way to resolve the WhatsApp issue! You just disable the Opera Max app from you Samsung J7 mobile set. Opera Max is a built in app - which may create problem while disabling. However, I've not observed any problem after disabling it. Now I'm getting WhatsApp notification. Happy!

Thanks and regards,
Dev

Ihsan Wan

Reply
  • Forum posts: 73

Oct 6, 2016, 1:56:40 PM via Website

At long last got an answer for the whatsapp notice issue after numerous months......

I am utilizing Samsung Galaxy J7.

Companions, take after the way:

Settings->Data Usage->Select Whatsapp-> And ensure Restrict foundation information is unchecked.

I did likewise. It worked for me.

Trust it will work in u tooooo.

Ihsan WanTerrence Human

Reply
  • Forum posts: 1

Oct 8, 2016, 6:31:42 PM via Website

Thank you.
This works on the Galaxy S7 Edge as well.

Reply
  • Forum posts: 1

Nov 20, 2016, 6:50:35 AM via Website

friends i have samsung j2 2016 modle and am facing same problem notification are nt show on phone in lock screen then i open menu then settings then smart manager and power seving mode is of and notification are show in my phone lock screen

Reply
  • Forum posts: 1

Jan 19, 2017, 5:49:24 AM via Website

Update your Android System Webview.
AKV.

— modified on Jan 19, 2017, 5:50:43 AM

Reply
  • Forum posts: 1

Jan 21, 2017, 2:15:25 PM via Website

Dear all, I have motoG4 plus and suddenly WhatsApp notification is not showing in my screen and no ringtone ringing at the time of incoming WhatsApp sms. Can u help me. Before update missed call notification did not showing but other all notification was showing properly. after update now missed call notification is showing but WhatsApp notification suddenly not showing in home screen.

Reply
  • Forum posts: 1

Mar 10, 2017, 10:32:35 AM via Website

Hello,
Hope all are doing well.
This post i am writing for those, who are facing issue with whats app notification’s.
I have came up with the solution as I was facing the same issue that I was unable to receive the what’s app notification messages when the screen of mobile was locked/Off.
So what i have done to get rid of this problem is are as follows :
1) First I have uninstalled the whats app and re-installed the app again.
2) Second I have not restore the data.
3) I have skip the chat backup while un-installing the app.
4) Directly get login to whats app.
5) Then you have specifically check that the background data is not restricted for GOOGLE PLAY SERVICES.
6) If it is so change it orelse you will not able to received the notification.

7) You will start receiving the notification.
So by doing all this my issue as be resolved please let us knw if your issue also get solved.
Thanks ,
AP
strong text

Ihsan Wan

Reply
  • Forum posts: 1

Mar 14, 2017, 1:21:02 AM via Website

I am having the same problem. If I don't open manually, I am not notified

Reply
  • Forum posts: 1

Mar 17, 2017, 5:46:55 PM via Website

Thanks
It Works
Just go to Settings>> Apps >> Whatsapp >> Check Show Notifications
ans done!!

Ihsan Wan

Reply
  • Forum posts: 1

Mar 24, 2017, 6:50:32 PM via Website

l am using j3 (2016) model and had that problem. Click Sound and Notification 》Application Notification 》Whatsapp 》Set as priority.

Ihsan Wan

Reply
  • Forum posts: 1

Mar 27, 2017, 8:40:18 AM via Website

I have a Samsung J7 (prime) and was facing the same problem. After reading the experiences if the members i hit upon a solution. My hand set came with a default apps from Opera Max with a ULTRA DATA SAVING MODE ENABLED as default. In fact you may find this in the notification area most of the time.
Tap on this notification to open the page and go to the LIMITED BACGROUND DATA area and tap on one the + signs there to add Whatsapp to exclude this application for the Limited BACGROUND DATA purview.
Once done, you should be able to receive whatsapp notifications all the time.
Hope this helps at least some of you!

Ihsan Wanwasi iqbal

Reply
  • Forum posts: 1

Apr 5, 2017, 5:39:20 PM via Website

Hi go to settings then select battery in battery check if you have intelligent standby power saving option uncheck that maybe it will work for you, waiting for your reply.

Ihsan Wan

Reply
  • Forum posts: 1

Apr 28, 2017, 4:57:53 AM via Website

100% working tip to get notifications.

People who always enabled power saving mode they are facing this prblm just have to do a simple step and your prblm of not getting notification will solve 100%.

Go to power saving mode and you will see down restirct background data you have to untick that and thats it your prblm solved.
Power saving mode restricting background it is clearly mention there that if you enabled restrict background mode then unless you open app you will not get any notification becoz power saving mode want to save ur battery for this purpose it it is stopping notifications previews.
For more information check out my youtube channel myartv .

— modified on Apr 28, 2017, 5:01:12 AM

Ihsan Wan

Reply
  • Forum posts: 14

May 15, 2017, 4:24:18 PM via Website

I have got the same problem no notification at all for any app...
I dont why but I am loosing so many updates(angry)
Plz help me guys......

Reply
  • Forum posts: 1

May 22, 2017, 3:42:46 PM via Website

Finally after reading the comments here i figured it out how to solve my problem. I dont receive notification in whatsapp, viber and new messages while my screen is locked/off also. If you are using a SMART MANAGER app just simply click smart manager > ram> auto run apps> them allowed all the appa that you want to get notification. I hope this is helpful

MaxHIhsan Wan

Reply
  • Forum posts: 1

May 27, 2017, 8:46:58 AM via Website

Juned Memon

I have got the same problem no notification at all for any app...
I dont why but I am loosing so many updates(angry)
Plz help me guys......

Try this; Select SETTINGS........DATA USAGE. Your Service provider will be displayed. ( In my case 2 Service Providers are displayed...Dual SIM). I use one for voice calls and the other for data. Tap your data Service Provider.....A list of Apps will be displayed.........Scroll to Whatsapp........and tap.....APP SETTINGS is displayed and below that.......RESTRICT APP BACKGROUND DATA. switch it off. Do the same for any other APPS. Note; I had no Background data restricted for any APPS in APPS MANAGER yet it was restricted in my ISP settings. I am on Android 6. Of course phones differ even when using the same Android version but hopefully this will assist.

Ihsan Wan

Reply
  • Forum posts: 1

Jul 6, 2017, 5:05:35 PM via Website

This was bugging me for a long time, and there might be a simple fix that worked for me, setting sound and vibration, then click volume, and there is more options for different volumes than the one on controlled by the volume at the side of the phone Ringtone, media, notifications,and system, on mine it was off, now it works.
(whew)

Reply
  • Forum posts: 1

Jul 8, 2017, 10:46:20 AM via Website

Thanks dear. It was helpful and I fixed my whatsapp problem. I was not getting msgs untill i open it manually.

Reply
  • Forum posts: 1

Jul 24, 2017, 7:02:55 AM via Website

i am facing same prob with my samsung a9 6
i cnt get any notification if i will not open it manually

Reply
  • Forum posts: 3

Jul 31, 2017, 4:26:03 PM via Website

On my S8 Nougat. Settings, notifications, all apps. Move the slider to the right and Bob's your .....
Alternatively, settings, apps, go to whatever app and click on it. You will see by app settings Notifications either blocked or allowed. Change to your preference.

Reply
  • Forum posts: 1

Aug 6, 2017, 11:10:02 PM via Website

This applies to most incarnations of Android 6.0 and 7.0

  1. Head for the ‘Settings‘ app and then ‘Battery‘.
  2. On the ‘three dots‘ menu, top right, you’ll find ‘Battery optimisation‘. OR 'Background activity manager'.
  3. "Turn off" the Optimiser for all the apps.

KidukiduDeepak Bisht

Reply
  • Forum posts: 1

Aug 14, 2017, 9:38:22 AM via Website

Wow thanks a lot. I helped my friend which is having a same problem like this and she's using samsung j1 mini. && it's really work thanks! :)

Reply
  • Forum posts: 1

Aug 18, 2017, 8:29:36 AM via Website

you turn off the ultra data saving mode. i think this fetchers is enable in your mobile.

Reply
  • Forum posts: 1

Aug 18, 2017, 7:40:05 PM via Website

I want to say thank you, this actually solved the issue, i was going to return the phone back but tried this first and everythings great now.

Reply
  • Forum posts: 1

Dec 11, 2017, 11:46:49 AM via Website

You first backup your WhatsApp chat to google drive by going to Chat-> Chat backup-> then backup manually. before that uncheck the include video.

Then after going to app manager, click WhatsApp and open it. Clear the cache and then clear the data. Then comeback and restart your phone. Open WhatsApp. Login with your number and allow restore. After then, there will be no problem. I just have done this after seeing this post.

Reply
  • Forum posts: 1

Jan 5, 2018, 7:47:26 PM via Website

have been facing this problem since months and finally found out the solution.....thanks a ton...

Reply
  • Forum posts: 1

Mar 10, 2018, 8:47:48 AM via Website

Hi All,
I am having the same issue on my Galaxy S7 Android 7.0. Over the last week my whatsspp and Gmail apps have stopped working at some point everyday until i turn my phone off and on again and they work again for a few hours.

Not had any issues over the last year, always received notifications on emails and whatsapp messages. Even on muted conversations the number would appear next to whatsapp Icon to indicate an unread message.

I have read this thread and tried all suggestions but it still keeps failing at some point everyday, ill click on my whatsapp icon that says no new messages or my email icon and it will load messages that are a couple of hours old.

Sure enough, I turn phone off and on and then next few hours notifications work like normal. I have never needed to change all these settings on my phone to get notifications so dont know why i would suddenly need to now.

Any other suggestions anyone?

Thank you.

Reply
  • Forum posts: 1

Mar 22, 2018, 11:49:11 AM via Website

Dear prodeep finally your whatsapp working? Coz i am facing same problem. If you solved, pls tell the option how can i fix this

Reply
  • Forum posts: 2

Jun 8, 2018, 12:06:47 AM via Website

  1. Go to application settings and clear cache.
  2. Check if ultra data savings is ON, IF YES add whats up application in exception list , so that what up can work in background to receive calls and sms. Hope this resolve your issue.

Reply
  • Forum posts: 13

Jun 28, 2018, 9:24:43 AM via Website

Hi Pradheep,

I got you some fixes. Hope it works for you !!

Follow the below steps:

WhatsApp > Settings > Notifications

Under Notifications you will find many options but you have to scroll down and select “Pop Up Notifications”.

A Small window will appear with the following options:

1. No popup
2. Only when screen On
3. Only when Screen Off
4. Always show Pop up.

If you want to see a pop up on your lock screen even when the display is off click on Only when Screen Off this will help you to get messages from contacts as notifications on your lock screen.

OR

You can try this too

Go to Application Manager > WhatsApp
You will see Notification and it may be disabled.
Click Notifications > Allow Notifications

Hope any of the ways helps you out buddy!!

Cheers

— modified on Jun 28, 2018, 9:33:07 AM

Reply