Huawei Honor 6 Plus PE-TL10 Recovery Partition issues.

  • Replies:3
  • Forum posts: 2

Sep 11, 2023, 2:41:17 PM via Website

I have 8 years old Honor 6 Plus PE-TL10 running android 4.4.2 and I unlocked its bootloader and also Flashed official Stock Rom back then with proper ROOT access and I did flash CWM Recovery. Anyways Fast forward to 2023. I need this phone to be updated to Lineage OS 17.1. I tried to locate and Flash the Lineage OS through my Toshiba 64 GB SDCARD from my Samsung Galaxy S20 Ultra but in CWM Recovery, the HONOR 6 PLUS phone failed to locate the Lineage file from my SD CARD. I wonder if CWM recovery actually failed to even recognize my SD-CARD in the first place. But back in its official kitkat 4.4.2 ROM, the Honor 6 does recognize my SD-CARD. anyways. I tried to flash TWRP 3.1.xx whatever the latest version is there on TWRP website using FASTBOOT cmd prompt, it did show me progress in Flashing under 1.57 seconds but when I reboot into Recovery, CWM is gone and now the phone is stuck at HONOR 6 Boot Screen Logo (when I reboot into recovery using POWER BUTTON + VOL UP KEYS). Similarly, I can reboot into System partition to my 4.4.2 ROM but even if I try to Reboot from TWRP app into Recovery Partition, it does the same thing again. Stuck at boot screen logo and no TWRP. Similarly, I tried to flash TWRP 3.0.x.x version and no success. Same thing. Now I don't have a working Recovery at all. Neither CWM which is gone, nor TWRP which doesn't boot.

I also tried to display the partition tables using ADB SHELL but it does not succeed by saying NOT FOUND or something like that. I want to actually install TWRP as my recovery so I can flash Lineage OS to upgrade my Phone. I wonder if Recovery Partition is even working or detected because if I run "Fastboot boot twrp.img" it gives some error saying "Cannot be done"...

Kindly assist if anyone does have any idea on all of this.

Michael Mao
  • Forum posts: 1

Sep 13, 2023, 3:40:03 AM via Website

I am doing the same thing now, and can't go into TWRP

Journey Through Time
  • Forum posts: 28

Sep 13, 2023, 9:43:20 AM via Website

It seems like you're facing several issues with your Honor 6 Plus when trying to update it to LineageOS 17.1 and installing TWRP recovery. Let's try to troubleshoot these problems step by step:

Recovery Partition Issue: It appears that your recovery partition is either not working correctly or not recognized by your device. This can be a critical issue when trying to install custom ROMs like LineageOS. Here's what you can try:

Re-flash TWRP: Since you've mentioned that you flashed TWRP but it doesn't boot, try flashing it again. Use the fastboot flash recovery twrp.img command. Make sure you download the correct TWRP version for your device.

Recovery Partition Check: You can use the fastboot getvar all command to check if your recovery partition is recognized by your device. Look for the "partition-recovery" entry in the output. If it's not there or shows an error, your recovery partition might be corrupted.

Partition Repair: If your recovery partition is indeed corrupted, you may need to repair it. You can search for specific instructions on how to repair or recreate the recovery partition for your Honor 6 Plus model. This process can be device-specific, so be cautious and make sure you have a backup of important data.

SD Card Detection Issue: If you suspect that CWM recovery doesn't recognize your SD card, you can try the following:

Make sure your SD card is properly inserted and not corrupted. Try using a different SD card to see if the issue persists.

When using CWM or TWRP to flash LineageOS, try using an OTG cable and a USB flash drive instead of the SD card. This can help determine if the issue is with the SD card or the recovery itself.

Boot Loop Issue: If you're stuck at the Honor boot logo after flashing TWRP, it could be due to a variety of reasons:

Try booting into TWRP immediately after flashing it with fastboot boot twrp.img before booting into the system. If TWRP loads successfully, you can then use it to flash LineageOS.

If you're still stuck in a boot loop, you may need to reflash the stock ROM to get your device back into a working state before attempting to install LineageOS again.

ADB Issue: If you're having trouble with ADB recognizing your device, make sure you have the proper drivers installed and that USB debugging is enabled in your device's settings. Also, ensure that you're running the ADB commands with sufficient permissions (try using sudo on Linux).

Please note that modifying your device's firmware and recovery can be risky, and there's always a chance of bricking your device if not done correctly. Make sure to do thorough research and follow the specific instructions for your Honor 6 Plus model. Additionally, it's essential to have a backup of your data and the original firmware in case anything goes wrong. If you're uncertain about any of the steps, consider seeking assistance from an experienced Android developer or community forum dedicated to your device model.

  • Forum posts: 2

Sep 18, 2023, 3:46:35 PM via Website

Thank you for giving this post your precious time and reply. Before I follow your provided solution steps, let me edit somethings. I found some older version of CWM from Honor 6 forums from XDA and tried to FLASH it and it did flash successfully using FASTBOOT but same thing. Not booting into CWM.

Secondly, I was able to look into my Partitions using the "ls -al /dev/block/platform/ff1fe000.dwmmc0/by-name" and it shows 2 recovery partitions. I am attaching the screenshot for this. Now I will follow your steps and let you know what are the results asap.image