Samsung Galaxy s7 stuck in reboot screen

  • Replies:2
  • Forum posts: 1

Feb 11, 2019, 2:56:42 PM via Website

I got this Samsung Galaxy s7 from a relative yesterday. He gave it to me after using for one month. I tried to use the S-health app but it did not allow me to use saying it won't run in a rooted device. So I downloaded Superuser SU and performed full unroot( I didn't know if it was actually rooted or not, i just straight did the nroot without checking.). Then I restarted the phone but it is just stuck at the Samsung logo. It's been like this for over an hour now and nothing happened . It's just stuck and the logo is glowing. Please help.
Also, the device's android version was 7.0 and when I tried to update it, it said that the current version was installed in an unauthorised way.

Deactivated Account
  • Forum posts: 821

Feb 11, 2019, 11:20:06 PM via Website

If that phone was actually rooted before you got it the previous owner may have removed 1 or some of the systems apps.
And that could have locked it up .
When you root a app it is completely removed from your hard drive. A unroot program will not bring it back!
As far as the attempt to update. The message you recieved is weird.
My galaxy s7 came with the 7.0 software already installed. And I purchased it last June.
Anyway... It sounds like that phone was improperly rooted. And the only way to fix is to find out which apps were removed then reinstall them!
And if the person that rooted that phone did not back up the apps before they rooted it. Then there is no way of telling what they removed and no way of reinstall it.

Deactivated Account
  • Forum posts: 12

Mar 15, 2019, 8:06:44 AM via Website

I think it's problem of Samsung system. You should flash a new ROM or firmware for your S7. Also this video can give some help.