Issues creating Adaptive SD both with adb and with RE on S7 herolte

  • Replies:0
  • Forum posts: 1

Jul 11, 2018, 8:19:51 PM via Website

Hello everyone,

I am desperately trying to get my SD card on my S7 (SM-G930F , herolte) to work as an adaptable storage. At first, I installed LignageOS and rooted through Magisk, because why not. But I found the ROM too unstable, and the infamous camera issue was a deal-breaker for me as I really need my mobile for my research (which is why I'm trying to use adaptable storage, my internal storage is full and the mobile lagging).

So I reverted to the stock ROM, and - why not - I treated myself to the most recent firmware update, with Oreo (8.0), still rooted with Magisk.

I then tried to format my SD card through adb, as shown here, running these lines in the terminal with the USB-debugging mode activated (both with the SD mounted and unmounted):

Grillotalpa:~ xain$ adb shell
herolte:/ $ sm set-force-adoptable true
herolte:/ $ sm list-disks
herolte:/ $ sm partition disk:179,0 private
herolte:/ $ sm set-force-adoptable false
herolte:/ $ exit
Grillotalpa:~ xain$

... to no avail. The SD stays untouched.

I then tried to format it through Root Essential, but RE requires me to flash the ASP plugin. I followed their instructions, and the phone reboots in recovery mode. But once in TWRP, no rest for the wicked:



I already tried to wipe everything out, format /data with another filesystem and then re-format in ext4 - that solves the "invalid argument" issue in a rather brutal way (at the cost of all my data and settings), but still doesn't allow me to flash ASP (as "Root Essentials is not installed").

Any possible way out or workaround ?

Be the first to answer