SD card cannot read

  • Replies:10
  • Forum posts: 22

Apr 11, 2018, 11:32:00 AM via Website

Hi there,
I bought a sandisk 64GB original, and when i insert it to my phone it says SD card not inserted. Tried it many times. Please help

  • Forum posts: 1,457

Apr 11, 2018, 11:55:13 AM via Website

Examine the manual that goes with your phone to check whether this SD card has too big capacity or uses unknown specifications.
Maybe you'll have to get another SD card compatible with your system requirements.

Download size < 0.08 MB. But also Ad-free, Pure & Accurate enough.
The minimalist app is available on Google Play
Your 5-star is appreciated. Blog:

  • Forum posts: 105

Apr 11, 2018, 10:03:56 PM via Website

Try using a microSD card adapter and see if a PC PC is able to read the card. If your PC is able to read, the phone may not recognize the card. If your PC can't read, then the card may not be good. I have friends who have had problems with the Sandisk microSD cards, with 32 or 16 GB capacity (with 64 GB I do not know how to behave). One card was changed twice, and only the 3rd card was good.
Try first to see if a PC or laptop can read the card.

Deactivated Account
  • Forum posts: 29

Apr 12, 2018, 3:22:42 AM via Website

Yes, try to connect the card to your PC. There are several causes that may lead to undetected SD card, and you should first eliminate the problem of memory card itself. You can refer to this article to fix it.

  • Forum posts: 4

Apr 13, 2018, 9:26:38 AM via Website

On the off chance that it was setup as inner memory, control the gadget off, evacuate and reinsert the card and power on, on the off chance that regardless it isn't perceived and you are not established as of now, you have likely lost everything.

On the off chance that the card was outer (convenient) capacity, evacuate the card and place it in a card peruser and attempt to duplicate off any information then reformat the card and reinsert it into the telephone, in the event that it is perceived at that point duplicate the information back and have a go at utilizing it.

  • Forum posts: 2

Apr 17, 2018, 7:14:33 AM via Website

change the device on which you are trying to get it.

  • Forum posts: 1

Apr 18, 2018, 10:33:01 AM via Website

Bitwar Data Recovery provides a free scan preview, and the preview file is intact and can be restored.Lost the data?Accidentally deleted files?Quick preview using Bitwar Data Restore.

  • Forum posts: 13

May 2, 2018, 12:41:09 PM via Website

Well, this has become one of the general issues. But you don’t have to worry about it at all. You can fix micro SD card not read issue.

Here follow the solutions:

1: Switch OFF or Reboot the Phone

Sometimes switching OFF or rebooting the tap will help you to recognize your memory card.

2: Pull out the SD card and Re-Insert It

If that fails, then remove the card out of the Tab 4 and then re-insert it and check if problem is solved or not.

3: Apply CHKDSK To Fix Micro SD Card Cannot Read Error

• Remove unrecognized card out of the Tab 4, insert it into the card reader and connect it to PC.
• On your PC, click Start> type CMD in search address bar and hit ENTER.
• Now type the following command in the new opened window: “chkdsk /X /f H:” or “chkdsk H: /f” and hit ENTER. Here you need to replace H: with your micro SD card letter name.

After successful process, disconnect the card form PC and re-insert it back to your phone.

I hope now your problem should be gone.

The solution is brought to you by -

  • Forum posts: 22

May 12, 2018, 5:13:04 PM via Website

Looks like problem is only with the phone not with the pc.

  • Forum posts: 15

May 31, 2019, 5:14:21 AM via Website

Connect your SD card to another phone or PC to check whether it's a faulty SD card. I had the same problem before. When I inserted my SD card to my phone, the [SD card not reading][1]. And I used [Bitwar][2] to get back the data which had lost. Maybe you can try it.

— modified on May 31, 2019, 5:19:11 AM

  • Forum posts: 8

Nov 5, 2019, 8:24:51 AM via Website

Format the sd card once, maybe there are viruses that's why it is not reading.