Samsung Galaxy S3 — S3 - broken Screen - Adb Unauthorized - How to access?

  • Replies:0
  • Forum posts: 1

Mar 21, 2017, 4:38:20 PM via Website

Hi, first of all sorry for the spelling, i'm from Argentina and my english is not the best.

i have a samsung s3 phone with a broken screen. I think also the touch-system is broken.

I want to access the device via VNC to configure it as a media server, or a camera or maybe buy the mhl cable and use it as a smart-tv.

I tried to install every app available but all of them requires me to authorize the adb interface (i have it enabled).

on the adb command linethe phone shows as "unautorized"

i tried the solution of rebooting the phone on recovery-mode and change the adb hosts files to have it autorized with no luck.

In my several tests i think i broke the download mode and recovery mode because now it doesn't seems to reboot in those modes, it always boots in normal mode no matter wich keys i press.

So, now i have a working cyanognemod rom (i don't remember wich version, if it's a 5.0 or 6-0 rom).

I don have acces to recovery mode.
I dont have access to download mode.
I don't have wifi connected.
I have adb enabled.
I dont have adb autorized.

I tried the vysor app, the teamviewer app etc.

Is there any app to access the phone (vnc, or edit system files remotely) without autorize the adb interface?

I bought a usb-jigg (it on its way) but i think it wont help, maybe it will allow me to enter download mode, but if i flash a new stock or custom rom i will be in the same place, because i dont have a way to autorize adb whitout a working screen

So, i woinder if there's an app or script to authorize adb, or directly to access the phone wihout having to enable it

Thank you in advance