Motorola Moto G — Can't connect to PC

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Oct 1, 2016, 10:25:32 PM via Website

I currently have a moto g (3rd gen) and am running android marshmallow. I have had it for a while, and have had no problems. All I want to do is transfer some music files from my pc to my phone. When I plug my phone into a USB, it does not show up in any capacity on my PC. I have tried multiple other devices in my USB ports and they all work fine. I have tried lots of different cables with all of these devices, and there is no difference. I have enabled developer mode and enabled USB debugging. I have installed and reinstalled drivers. Both my PC and phone are 100% up to date. All I get is my phone tells me that it is charging, but no option to enter MTP mode, and a beeping noise when I plug it in to the USB from my PC (like any and all other devices I plug in).

I literally can not think of anything else to do, is there anything I can do, or is this a case of the pins in my phone are done?
Please help!

  • Forum posts: 73

Oct 10, 2016, 11:43:26 AM via Website

This is a known issue with the Marshmallow update on G3 with SD card set as portable storage (users who switched to internal storage seem to have no issues)... Disconnect USB, then Go to Settings, Apps, and Show System Apps, then find External Storage and Media Storage, and clear data and cache on each one and reboot. Give it 5 min after full boot up to rebuild media databases and connect to USB and select MTP, should be good to go.

Recommended by NextPit