Doogee x5 max problems.

  • Replies:34
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Sep 10, 2016, 4:49:49 PM via Website

I have a Doogee x5 max, it's a nice phone in general, but I'm having problems with it. I was wondering if anyone could help me.

  1. There are popup ads constantly, and they're hard to close.
    These ads have been getting progressively worse.
    I've tried using the malwarebytes app to get rid of the popup adware, and when I try to uninstall the adware that it's detected, it just says "This program cannot be uninstalled." or something similar to that. It doesn't work.
    (it's a process/program detected that is called (and another one called FineSearch.apk)
    I'm not sure if these are the processes causing the problem, but I'd like to get rid of it.
    I've factory reset the phone, and the ads were still there. So I'm guessing that the phone comes with the adware.

  2. The camera does not connect.
    It worked fine when I originally had this phone, but after a while it stopped.
    I can screw around with the phone, reboot it, drop it a few times, and it WILL connect to the default camera app and take pictures with ONLY the back camera. I cannot use the front camera or it will stop working. Snapchat or any other app will not work with the camera, and when using those apps, the back camera stops working for the default camera app. I've tried clearing the cache, etc. but nothing seems to work, and the only solutions I haven't tried involve a root.

  3. I cannot root the phone with Kingroot, etc.
    The program says that "there is no root method for this phone" so I can't do a 1-tap root. I tried the "root anyway" option and it doesn't work. I've searched for a while for methods of rooting this phone, and the only things I have found were in languages I couldn't understand. I'm not sure how to manually root a phone if there is "no root method" but I do have access to a computer and I can use that if it is nessecary.

Can someone help me fix any of these problems? I can't really afford to buy a new phone right now.

  • Forum posts: 6

Sep 11, 2016, 5:34:23 PM via Website

Hi! I had/have the same problem. Ads began to appear in my phone (not porn but annoying anyway).

I haven't found a way to root it yet, but I've installed a firewall (Look for No Root Firewall in the Store).

It will alert you of any app trying to connect to the internet. Once you see an app called "", then block it.

After doing this procedure, the ads dissapeared.

Kathleen MacleodPaolo Falcioni

  • Forum posts: 2

Sep 13, 2016, 5:36:57 AM via Website

This does not seem to work for me.

  • Forum posts: 6

Sep 15, 2016, 5:45:51 PM via Website

Forgot to mention to also disable the app (but you'll have to do it everytime you reboot your phone).
Anyway, this is the procedure that has worked for me.
I'm still trying to find out how to root the phone too.

About the camera problem... I've read in other forums that some people are having the same problem after they did the update (dated July 2016). I still have the version from May, which I believe it's the original one and doesn't have that issue. As far as I know.


P.D. Oh, and also block and disable the app for System Update (I'm not sure about the name as I have my phone set in Spanish) and DG Xender just in case.

— modified on Sep 15, 2016, 5:54:24 PM

Deactivated Account

  • Forum posts: 1

Sep 29, 2016, 5:13:21 PM via Website

Hi I have exactly the same problem, i found this out...

From Patty C
Dear Doogee:
There is a bad malware app that is pre-installed called
it's located in folder /system/priv-app/
i think it is displaying ads in my home screen!
antivirus can't delete it because the phone is not rooted.

I installed total commander and i see that i have that folder in my phone, but just can't delete it yet, i don't now how to root it yet.

  • Forum posts: 1

Oct 4, 2016, 11:30:30 AM via Website


I just discovered the same problem. I used the app "malwarebytes" to discover "" as the causer.
I had also pop upping ads everywhile. Once accidentally I clicked on one an I was forwarded to the play store.

For now I am using a no root firewall (although I don't know what "no root" means, maybe someone can explain me).
I just denied the communication in the firewall and it works but I would like to get rid of the malware, out of the phone. I would be thankful if someone has a solution.

Deactivated Account
  • Forum posts: 1

Oct 5, 2016, 6:07:31 PM via Website

Many thanks to you, Gonzoco Loco! This problem started on my X5 Max after the July 2016 system update. My anti-virus detected "" as the source of the very annoying slide-in ads but I could not remove or disable the app. Then I followed your advice by using NoRoot Firewall and it works a treat. Most grateful!

— modified on Oct 5, 2016, 6:09:19 PM

Shawn whitty

  • Forum posts: 6

Oct 5, 2016, 6:19:41 PM via Website

Hi Andrew! I'm very happy that my recommendations have helped you :)
Just in case, go to Settings > Applications
Click on the three vertical points in the upper right part of the screen and tap on "Show system apps" (or something similar)
Look for and delete all data it may have gathered. Also remove all permissions, then force stop and disable the app.

Please notice that everytime you reboot your phone, the Snap app will reactivate again and you have to repeat above steps to disable it.


— modified on Oct 5, 2016, 7:37:49 PM

  • Forum posts: 2

Oct 6, 2016, 9:54:23 AM via Website

Where i can find this android version?

  • Forum posts: 6

Oct 7, 2016, 5:15:07 AM via Website

Hi Tetsu. Do you mean Doogee's latest update?

  • Forum posts: 2

Oct 23, 2016, 3:53:49 PM via Website

No. I mean update before camera problem's.

  • Forum posts: 2

Nov 6, 2016, 12:22:35 AM via Website

Hi, I contacted the seller of my Doogee concerning the malware/adware problem and got this answer with which the malware should be deleted. Unfortunately, I am not a Android-Software-Professional, so maybe someone checks this "solution" provided by the seller. If it is a good solution, to a lot of us help is found. :)

the problem is still there? your phone shows it's malicious software? Please upgrade to the latest version of the system.

Brush pack:
Brush machine

  • Forum posts: 2

Nov 6, 2016, 12:30:59 AM via Website

Edit to my last post with the links: As I am a new user and this was my first post, I was not abele to post the whole links.
So before the first, thrid and fourth link, a "https"+colon+Slash+Slash has to be added, to get directly to the download and not to the forum regristration.

  • Forum posts: 1

Nov 18, 2016, 8:18:42 AM via Website

Hello! I have read your instructions and try to look for I stopped this app and remove all permisions. But I can't disable it(((. Button "Disable" is not active. And after stopping, it starts again. Now I use NoRoot Firewall. But maybe malware delete without root?

— modified on Nov 18, 2016, 8:21:40 AM

  • Forum posts: 2

Dec 15, 2016, 3:49:23 PM via Website

Hi HelgaHelga and all others. Just finished doing what Gonzoco Loco recommended and got it right on the snap app. It,s gong and not returning at least for now. No need for any other download though. What I already new was that the main culprit in our x5 max would be non other than the XENDER app (among some other apps possibly).
Ones you get into the Xender app. disable the camera access (I dissabled entirely) and the snap will stop. It works fine now, but is not all perfect. Now i discovered that the FRONT CAMERA is not working when engaged as before. It will get fast frozen when selected and you need to do a reboot to get it working again.
Cause i never used the front camera can't tell if it was ok before this handling or it is a consequence of it. For now, i am just happy got rid of that popup. Will keep playing with it and even do a factory reset and see what new that brings along. Salut

  • Forum posts: 1

Dec 28, 2016, 10:41:49 PM via Website

Just found at settings -> battery with 3% of battery usage.

So I searched for it and found this discussion here.

Settings -> applications - system
It was possible to deactivate. After reboot, it was still deactivated.

I have also deactivated Paralell Space and Xender before.

My phone is at the firmware update 2016-12-26

Salomon Andreia

  • Forum posts: 2

Jan 18, 2017, 11:46:42 PM via Website

Sinds my last post had no more problems with cellphone.
Sinds 16-01-2017 i am receiving an official update from doogee. My questions is...Are there more ppl who got it ? Would it be safe to download? Last update looked different that this one, being this one like more professional than the first download.
Till i read some more positive reviews i won't let it happen.
Download title says will sort out some minor issues.
My front cam still not working.

  • Forum posts: 1

Jan 19, 2017, 11:02:04 PM via Website

Did you fix your problems? I'm looking at it costing $59 at Geekbuying, might get one.

  • Forum posts: 1

Jan 23, 2017, 9:52:30 AM via Website

After reading what you wrote it seems your the one who has helped a fair few people out with advice on there doogee is there any chance you can dum it down for me please to like an idiot's guide if you like I've installed the no root fire wall but don't have a clue how to use it would be really helpful if you could thanks

— modified on Jan 23, 2017, 9:53:20 AM

  • Forum posts: 6

Feb 19, 2017, 8:09:18 PM via Website

gary dennis

After reading what you wrote it seems your the one who has helped a fair few people out with advice on there doogee is there any chance you can dum it down for me please to like an idiot's guide if you like I've installed the no root fire wall but don't have a clue how to use it would be really helpful if you could thanks

Hi Gary. No problem.

  1. Open No Root Firewall APP
  2. In the upper section, you'll find an "Apps" tab. Go there.
  3. All your installed Apps are listed there: It's icon, two little squares (boxes) and the name of the app.
    Find the one called "" and mark both squares. Tap on them until you find the red X (look the attached picture please) and that's it. In this way you block the app from accesing internet in Wi-Fi and Mobile Data mode.

I recommend you to do the same with the System Update, Calls Administrator and Xender.

Sorry for the late reply but I'm not checking the forum as often as before. Cheers!

— modified on Feb 20, 2017, 4:15:32 PM

EddieAnders Bergåker

Recommended by NextPit