Samsung Galaxy S3 — Google service error even after hard reset

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jun 29, 2016, 6:46:20 PM via Website

Hello there,

I have been having a google play services/hangout/maps/youtube (google related) everything google problem for a couple of weeks now. After finally getting over it I tried all the fixes, cache clearing, updating version etc.... but nothing worked. So I finally tried a factory reset... this also didn't work. I made it as far as the wifi setting all the while still getting the google services errors but then it just sent me back to the startup page (where you choose the language).

So in desperation I tried the hardcore reset (hold the volume button, the power button and the home button etc.....) with the same result. As far as the wifi setup, but now stuck back on the language setup page all the while getting the 7 - 9 google services errors.

PLEASE HELP!!! heheh at least before the pop ups were well annoying... but I could use my phone, now I can't even use my phone. Any assistance would be appreciated.

  • Forum posts: 251

Jun 29, 2016, 9:09:29 PM via Website

You will probably get a generic response (such as factory reset, etc) here if you do not post screenshots or the error message.

Recommended by NextPit