Google play services gone. Help!

  • Replies:0
  • Forum posts: 1

May 26, 2016, 4:18:02 PM via Website

Hi I have an android car stereo...I think what has happened is I've turned the engine off mid update and system has got itself in a pickle!!

Device still works find but I get a few error messages on start up. Something to do with unstable UIDs and a few apps stopped working messages.

It looks like it's all to do with Google play services no longer on my device...I have tried the following;
-full device reboot
-looking for Google play services on the installed or running apps in the settings to clear data and cache but it's not there
-can't sign into Google play store because of above to download GPS..

I've tried to download GPS apk manually and install it but go error message could not install. I possibly had wrong version, who knows!!

I've run CPUZ to get my device configuration;

Kitkat 4.4.4-13072015
800 x 480 pixels
3.67" screen
254 dpi
1.6ghz (x4)

Can someone give me link to the right apk for GPS so I can download and try fix it..

If not any other resolution.