Samsung Galaxy S4 — Samsung galaxy s4 can't be installed

  • Replies:2
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Apr 22, 2016, 3:26:43 PM via Website

After trying to factory reset my Samsung galaxy s4, the telephone does all necessary procedures and goes to language installation, l leave in Holland so the language comes in Holland language so l want to install it in U.S English but when tap on the language to change to other languages the telephone does not react. I tried to tap on the next bottom but does not also react and don't know what to do. Infact it is not the first time for me doing that so l am really shocked since it is the first time ever me seeing such a thing.
But it seems to me the telephone didn't get software?
Please who can be nice to help me out. Another Samsung galaxy s4 mini also instead of connecting to wifi would only save to wifi and as a result cannot put in gmail account to install things like WhatsApp viber and others.
Hope someone somewhere would be able to help me out.
Thanks and waiting for anybody's help.

  • Forum posts: 266

Apr 22, 2016, 10:27:06 PM via Website

Hi, did you try to factory reset your phone one more time?

  • Forum posts: 2

Apr 22, 2016, 11:09:17 PM via Website

Oh yes have done that for about more than 4 times now. Have just tried another phone to see what the difference is and saw that the procedures are the same. Therefore l am wondering why the hell is going on with the Samsung galaxy s4.
So that is that friend and thanks for your help but still needs more even tried the root the phone to see if that may have helped but to no avail. Rooting did work either.

Recommended by NextPit