Samsung Galaxy S5 Mini — SOMEONE PLEASE HELP ME!

  • Replies:2
  • Forum posts: 2

Apr 5, 2016, 10:08:50 PM via Website

Hello everyone,

I am writing cause I need desperate help. I'm so frustrated now that I want to cry, scream, whatever, and I'm about to through my cell ph against the wall.
I just bought my cell ph Samsung Galaxy S5 mini SM-G800H/DS on may 12 2015; It worked like a charm but yesterday, all of a sudden, around noon, I took out the cell ph out of my purse and I saw this message
"Device memory damaged The data partition has been corrupted. You need to reset your device to factory defaults. This will erase all your data".
There is a stupid button below that says Reset Device, and I say stupid cause I tap on it and it does nothing.
I went to my cell service provider's shop and they said couldn't help me cause I didn't get the cell ph through them, all I have with them is the mobile service.
I was googling and red a bunch of things which I didn't clearly understand cause I am not very skilled in cell phs as never had this type of problems. I thought the bottom line was that I needed to perform a hard reset on the cell ph.
So I connected the cell to my pc to see if I could rescue anything but my pc doesn't even detect it, on the properties it says "driver error".
I watched too many youtube tutorials to do a hard reset. After several attempts and different keys combinations (cause the conventional way doesn't seem to work for this ph) I managed to access the "recovery method" but guess what!. I just see the green robot that is stood up, then it lies down, on his stomach has red triangle with an exclamation mark, then the screen turns off, you can feel 2 short vibrations and the cell ph gets re-started, then I 'am back to square one with the silly message of "Device memory damaged"... At no point when I reboot the cell, and the robot appears, I get none of those options for wiping, factory reset, etc. I moved the volume key up and down and nothing happened. Sometimes if pressing the volume down key I got a warning message that reads:
"Warning!! A custom OS can cause critical problems in your phone and installed applications. If you want to download a custom OS, press the volume Up key.
I clicked volume up and got something about product name: SM-G800H, current binary: samsung official, system status: official and below reads Downloading... Do not turn off target!!" but nothing happened. The screen didn't disappear even when I pressed all the keys. I ended up removing the battery.

Before this nightmare occurred, every day I was getting a warning that my cell ph was trying to get a software or firmware update, I don't remember quiet well, the update used to fail cause apparently it required wifi connection, which I don't have, or that I updated it from my pc which I didn't either cause didn't have time. Besides that, I download my apps from google apps; I have no strange apps, nor strange surfing habits, I scanned the cell every day with 3 different antiviruses so I know it was clean, as I would have noticed before if it was infected. As I said, it worked as a charm until yesterday.
I know it has only a 30 day warranty so at the place where I bought it they will charge me, not sure how much if I take it there. If I need to I would but I have no time at the moment and I really need it.

I see this is a new post. I hope someone can help me please :'(

  • Forum posts: 20

Apr 6, 2016, 1:40:05 PM via Website

I guess that your phone is still within the manufacturer's warranty period.
If you have effected a reset to no avail then contact the phone vendor. Not the service provider, but the firm you originally purchased the phone from.
Ask them to help and be willing to send or take your phone to them. Push the warranty angle as you think it may be an internal memory issue...

I have 3rd party insurance on my phone through my bank and have had to use this as the manufacturer told me my phone was beyond economical repair when it died after 2 years use.
Turned out to be a mechanical failure of a component so why it wasn't under warranty I don't know. But my bank's insurance got it repaired by the same firm within 2 weeks.
It is worth considering this type of insurance - I'm with the Halifax and have an Ultimate account with them.

One last thing - when you're up and running set up cloud backup of photos, synchronise on acts and emails with Google or a similar account...

Good luck.


  • Forum posts: 16

Dec 7, 2018, 4:17:12 AM via Website

Have you tried using the Odin Flash tool to solve the problem? This seems to be one of the common solutions for the Odin model.
- Download the Odin Flash tool and the appropriate firmware and driver software on your computer and select the "Run as administrator" option.
1. Press and hold the power, lower the volume and home button, activate the device to download mode, and release the power button while the device is vibrating. Then gently press the volume up button to enter the download mode screen.
2. Connect the Samsung to the computer with a USB cable, then the Odin flashing tool will automatically detect the connected device
3. Click on “PDA” or “AP” in the Odin window to find the firmware. Finally click "Start" to solve the problem.
I hope that you can solve the problem through this method. However, this method does not work for me, I am using other methods to fix the problem of the card in Odin mode.

— modified on Dec 14, 2018, 4:57:21 AM