Google Nexus 5 — Nexus 5 file transfer problem

  • Replies:5
  • OpenNot stickiedUnanswered
  • Forum posts: 4

Oct 17, 2015, 4:44:33 PM via Website

I just bought a Nexus 5 off someone. Upgraded to 6.0 because I heard it's good.

When I connect to my computer running Windows 7, the driver seems to install properly (i.e. When it finishes installing, it says "Nexus 5"). But when I double click Nexus 5 in My Computer, nothing is showing in there.

I heard that when the phone is connected via USB, it would give a prompt as to what USB mode I'd like. Never seen it on mine.

I went into developer mode, found "USB connection mode" option, and "MTP" is selected, which as far as I know, should be the option selected.

Later, when I played around with it, I realized that after connecting via USB, then change the mode, say "Picture Transfer", I would be able to see the removable drive, and pictures; and after that, if I change the mode back to "MTP", I see everything.

Any ideas as to how to go around this? Thank you!

  • Forum posts: 1

Oct 18, 2015, 4:49:02 PM via Website

You need to turn on the "USB Debugging" options

You Need to go to "Settings"
scroll down to "About Phone"
Then tap "Build Number" 7 times
This will then allow you to add "Developer Options"
once in "Developer Options" you need to turn on "USB Debugging" option

  • Forum posts: 4

Oct 19, 2015, 2:07:24 AM via Website

I've already been in "Developer Options", and tried connecting phone with "USB Debugging" on and off. Neither seem to help.

  • Forum posts: 1,289

Oct 19, 2015, 10:00:33 AM via Website

Try to uninstall the driver from your Win7, device manager - "Nexus 5". Then reconnect your Nexus with Win7.

Download size < 0.07 MB. But also Accurate, Ad-Free & Full-Free.
The minimalist app available on Google Play
Your 5-star is appreciated. Blog :

  • Forum posts: 4

Oct 19, 2015, 4:47:52 PM via Website

I tried fiddling with the driver too. I also used "USBDeview.exe" included in a root tool to get rid of any USB drivers associated with the phone, and installed the official Google driver. Didn't help.

Maybe a hard reset is the one option left for me?

  • Forum posts: 4

Oct 19, 2015, 5:13:55 PM via Website

A bit of additional detail:

I've realized that when the phone is connected, the swipe-down area will display "USB for charging only". When I touch that, USB options appear (charging, MTP, PTP, MIDI), and charging is the selected option.

When I choose MTP or PTP, the phone behaves like it should, but when I disconnect and reconnect USB, it defaults to charging, and no prompt comes up, asking for USB mode. The behaviour doesn't seem to be affected by changing options under either "USB Debugging Mode" or "USB Configuration" under "Developer Options".

I guess my question now would be: Where is the setting that would either give me the prompt to choose USB mode whenever it's connected, or change the default setting (i.e. from charging only to MTP)?

Recommended by NextPit