Challenge of the Day: Can you reset the World's Most Stubborn Tablet when nothing works?

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jul 16, 2015, 9:21:28 PM via Website

I have an NATPC MO10SE 4gb (Ice Cream Sandwich) that is stuck on the boot screen.

I have tried:

  • the volume/power button combination, in every variation - no result.
  • downloading Multi Tool to do a data wipe via usb - but my laptop doesn't detect my tablet, even though it shows up in the Device Manager (but not Disk Management) and the Safely Remove Hardware icon appears, and I tried updated the driver software but "software is up to date."
  • Running the battery down - I get the desktop screen for a second and then it disappears as soon as I plug the charger in (the desktop background remains, just the apps and shortcuts and icons etc disappear.

The only thing I haven't tried is flashing it. Because I don't know where to find the firmware.

Why whhhyyy is the button combination not working??
And why won't my laptop detect the tablet?


PS: It's not an Amazon tablet, but I bought it from Amazon, there just isn't a sub-forum for NATPC - maybe a moderator could move it to a more appropriate sub..?