• Replies:4
  • Forum posts: 1

Dec 15, 2014, 4:19:30 PM via Website

Hi.. I own a Xolo A500 phone and I believe that I have bricked. Some vital info:
1.My phone is rooted.
2.I tried to flash a ROM to my phone, and I believe that I have selected a correct ROM.

After flashing , the phone got hung on the phone logo. So I reflashed it with the SAME rom. The same thing happened and suddenly my phone got switched off (May be the battery had got drained) and wont turn on again. So after recharging the battery, I tried again , but there was no respone, and may be the phone is hard bricked. I could not unbrick it by any means on the internet which i have tried. So is there any work around? Things I have tried, but in vain:
1. Used ADB, keeps giving me "Device not found" error
2.Used SP flash tool
3.OneClick Unbrick also gives similar"Not found" error

Another point worth mentioning is that in Device manager , it shows as QualcommHS-USB QDloader 9008.
Also, will a USB Jig work with my mobile? Any other ways i could unbrick my mobile?

— modified on Dec 15, 2014, 4:24:40 PM

  • Forum posts: 21

Apr 1, 2020, 4:10:08 AM via Website

You need to follow each and every step correctly while flashing stock ROM using SP Flash Tool. Again try flashing your Xolo A500 phone using the latest version of SP Flash Tool. Follow each and every step correctly while flashing the stock ROM.

  • Forum posts: 12

Apr 8, 2020, 5:07:05 AM via Website

Force factory reset bricked phone

  • Forum posts: 17

Nov 17, 2020, 6:59:02 AM via Website

I will try soon...

  • Forum posts: 16

Jan 15, 2021, 11:40:06 PM via Website

Haha, I had the same shit bro, I won't take any more chances