Samsung Galaxy S4 — Galaxy S4 Boot Loop problem

  • Replies:3
  • OpenNot stickiedUnanswered
  • Forum posts: 8

Dec 5, 2014, 2:52:25 PM via Website

Hey Guys,

This problem started a couple of weeks ago, where the phone would just shut off sometimes, and then, as long as there is a battery inside, even if I don't press the power button, the phone attempts to turn on, and it shows the "Samsung Galaxy S4 GT-i9500" big white text, and it keeps doing that every 5 seconds but the phone doesn't turn on. If I plug it into the charger, the symbol changes from the Galaxy one, to an empty Battery symbol, with the little loading circle on top of it, but it's a static symbol, and it also keeps disappearing and coming back every 5 seconds.

So, at first, I thought it was a Battery issue, so I ordered a couple of new batteries online... Got a new battery, and the new battery didn't work at first, still had the same issue, but after taking it out and putting it back in for like 5 times, it finally worked, and has been good for a couple of weeks.

Last night, my phones battery drained and shut off, and I wasn't able to turn the phone back on since, I'm still getting the same issue. I had 2 other new batteries lying around, tried both of them, but no luck. I tried using a different charger, still nothing.

I'm also unable to access safe or recovery mode, as as soon as I put the battery in, the phone automatically initiates the boot process, without me pressing the power button (Could the power button be stuck? AFAIK it's not, as the phone has been working fine).

Any suggestions?

  • Forum posts: 3

Dec 5, 2014, 3:54:23 PM via App

Did you try flashing your stock ROM?

  • Forum posts: 8

Dec 5, 2014, 4:24:53 PM via Website

My computer is unable to detect the phone in the current state... I can't access recovery mode either... I'm not sure how else could I flash the ROM...

  • Forum posts: 610

Dec 6, 2014, 12:44:52 AM via Website

There have been issues with the power button being broken or stuck. The simplest remedy seems to be to open up the phone and blow the button back into position. If it's not that then it could be a motherboard issue, which basically would mean sending it in for repair.


Recommended by NextPit