[Q] [N7105] bootloops / random restarts, worse with SIM inserted?

  • Replies:0
fight c.
  • Forum posts: 1

Nov 17, 2014, 10:35:33 AM via Website


when I started using my Note 2 LTE with an LTE sim card (tested LTE long ago without problems), running CM11 nightly from approx. 1 month ago, it started to reboot randomly. But it also happened with the other sim card without LTE, that worked fine before.
Updating CM didn't change anything.
Then I flashed the newest DBT stock ROM for the N7105 (N7105XXUFNE3_N7105DBTFNE1_DBT) (without knowing about the KNOX bootloader...). The behavior was the same with any of the SIM's inserted, but without SIM, it took hours compared to minutes or seconds for it to reboot.

Then I tried to flash the N7105XXDMB2-XEF-Service-Firmware (at this moment, I remember it was warranty void 0 and showed sw rev invalid magic string, EDIT2: perhaps did'nt want to downgrade the bootloader to a non knox version? but without also flashing bootloader it now doesn't flash, trying another old 4.3 formware which is without bootloader perhaps, but didn't work, can I remove it somewhere and how?... /EDIT2) with separated CSC, Bootloader, PDA, Modem and PIT. I also ticked repartiton.
Here the log output:
" Enter CS for MD5..
Check MD5.. Do not unplug the cable..
Please wait..
FULL_MODEM_N7105XXDMB2.tar.md5 is valid.
Checking MD5 finished Sucessfully..
Leave CS..
Enter CS for MD5..
Check MD5.. Do not unplug the cable..
Please wait..
FULL_CSC_N7105XXDMB2.tar.md5 is valid.
Checking MD5 finished Sucessfully..
Leave CS..
Odin v.3 engine (ID:8)..
File analysis..
Set PIT file..
Get PIT for mapping.."
It said "set partition" in the box where "PASS" also appears for more than 10 hours, then I unplugged it.
After unplugging:
" There is no PIT partition.
All threads completed. (succeed 0 / failed 1)

It didn't change anything, but when making a factory reset it even rebooted instantly.

I also flashed the pit file with repartition alone. but same behavior.
But after all of this, it was repartitioned.

I successfully flashed philz touch cwm, didn't change anything.

Now I flashed the newest DBT (N7105XXUFNE3_N7105DBTFNE1_DBT) again. No restart without SIM, but didn't test it for hours. With SIM, instant restart after entering PIN. And what's really strange... now it has an instant bootloop without SIM, too. Factory reset made it boot successfully again.

Is something wrong with my radio unit or what else could I try?


I now flashed philz recovery to gain root access, made that in the recovery, then I installed adbd Insecure v2.00 to have root adb when booting up. Without Sim card it was again fine for a long time and then i put my sim card in and logged proc/kmsg and logcat to files on my device via an adb command.
Here they are, I really hope some can have a look at it and perhaps find anything that helps!
en.file-upload.net/download-9867498/logcat.txt.html (was too big for pastebin)


I read that logcat and proc/kmsg is useless because it stops being recoded (at least being able to read it somehow), is that correct?

Here's the last_kmsg log from the same crash:

From another crash: pastebin.com/q7fj4byt

And the 3rd crash: pastebin.com/AV7RPquK

I removed the PIN with another phone, but it keeps crashing with that SIM and without SIM at all, too

I also tested the SIM in another phone, calling and SMS works, data still has to be tested in a smartphone.

I also wiped the EFS partition and restored an EFS backup. Wiped modem, too. Flashed the newest ROM (no matter which country), which is from Singapore (N7105XXUFNJ1_N7105OLBFNJ1_MM1, but has the same N7105XXUFND3 modem), but didn't change anything.
Flashed back newest DBT ROM (N7105XXUFNE3_N7105DBTFNE1_DBT) and Philz recovery.

I now managed to get a kernel log and logcat till after the adb connection is interrupted! (see here for how to do it: stackoverflow.com/questions/6071547/shutdown-log-in-android/27111185#27111185).

Of course the command stopped somewhere in the shutdown process, so they are indeed cut off in the middle of the line.

Normal reboot :
kmsg: nopaste.info/3e7eebd751.html
logcat: en.file-upload.net/download-9912275/logcat243_normalreboot-till-after-adb-disconnect.txt.html
last_kmsg: pastebin.com/GjkHkLAk

kmsg: nopaste.info/14cef13cdf.html
logcat: en.file-upload.net/download-9912298/logcat2416-till-after-adb-disconnect.txt.html

I wanted to get the last_kmsg from that crash but after the crash, it had a bootloop, which could only be fixed with wiping cache. Sometimes only a new flash via Odin helped then..
This is the last_kmsg after these bootloops, in contrast to my previous last_kmsg's it contains logs before the kernel restart, which could really be helpful!!! (didn't seem like a crash / panic / ooops in all the logs): pastebin.com/ikqkmeCh


Any help is much appreciated!

Thanks in advance.


— modified on Nov 27, 2014, 5:32:07 PM