Samsung Galaxy S4 mini — Recorded video "can't play" - help!

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Oct 29, 2014, 2:25:38 AM via Website

My phone is a Samsung Galaxy s4 mini
Today I recorded 4 videos. The main one is about 20 minutes long, saved in .mp4 recorded through the default camera device. I went to play it back on my phone, and when it got to about 4 minutes in, it suddenly said "can't play video" and that's it. I went out, went back into the video, and it played so I skipped past to about 6 minutes in and it was playing fine. It got to about 15 minutes and the same thing happened, but I can't get past that point. Now, it won't even play at all. Right from the start it just says "Can't play video". I have copied it to my laptop, and my laptop cannot play it. I even tried uploading it to YouTube (which can normally handle vids that won't play on my laptop) but it couldn't handle the file.

The video is 2.01GB, 1280x720 resolution, and it's an mp4 file.
The other videos I recorded have this same issue. I tried recording an playing back a new video of only a few seconds long, and it has the same issue. I do not know what is causing it but I NEED those recordings, they are very important and so I need to know how I can make them play again, and how to stop this from happening in the future. They played a few times originally, so there MUST be information there that can be recovered and made to work again.

Any info anyone has would be great.

Recommended articles