Huawei Ascend P6 — Notification led in only two colors and Play Store force closing issue

  • Replies:0
  • Forum posts: 1

Sep 28, 2014, 8:44:38 AM via Website

Hi, all.

I know this is an extensively addressed issue, but I can't seem to find a solution anywhere.

I just bought a Huawei Ascend P6, and at first everything seemed ok, but then I updated to 4.4.2 via OTA and Google Play Store just stopped working. It closes right after opening it.

I've seen many suggestion around and tried some of them, but none seem to work. The phone is not rooted.

Here's what I've tried so far:

  • Changing date and time
    No effect

  • Resetting app preferences
    No effect

  • Clearing Google Play Store data and cache
    Sometimes, after doing this, it'll start as if everything was fine, but as soon as I start a download, it closes. It'll force close on startup thereafter.

  • Clearing Google Play Store and Google Play Services data and cache
    Same result

  • Installing the latest version
    No effect

  • Installing older versions

  • Updating Google Play Services
    No effect

  • Factory reset (this was done from the phone options, not doing the volume/on-off key combination. Was that wrong?)
    No effect

  • Checking if the Android download manager was disable
    I couldn't find it in the 'all apps' list nor in the 'disabled apps' list. Every screenshot and video I've seen show the app with the classic green android as an icon, and they have different names ('Download manager' or just 'download'), but all I could find is an a app with a different icon named 'download' that seems to be a different thing. I suspected this might be the issue, but then I read that if I could download something from the web (which I can) then that's not the problem.

  • Clearing Google Services framework data
    Couldn't find it in the app list

I should mention that the only Google app installed was the Play Store and that some of the Google system apps like contactssyncadapter.apk and calendarsyncadapter.apk were not installed (before or after the update to 4.4.2), I had to download them from the web in order to sync my contacts and calendar from Gmail. I suspect that this might be the issue.

I know that you can download a .zip with all Gapps for custom ROMS that don't have them, but I don't quite know how to do it. The tutorials I've seen require root access and the ones that apparently don't require root access are extremely complicated, at least for me - obviously I'm no expert in this matter. It would be of great help if anyone could point me in the direction of a complete guide (preferably made for Android iliterated people like me) for installing this Gapps.

Additionally, I noticed that the notification led only responds if it's set to white, green or red (the white is more of a light green). Is it supposed to be like this or there's something wrong with my phone?

I'd really appreciate if you could shed some light here. Let me know if you need more information.

Thanks in advance.

— modified on Sep 28, 2014, 8:51:26 AM