Straight Talk MMS issue resolved

  • Replies:30
  • Forum posts: 5

Sep 7, 2014, 11:44:42 PM via Website

I have been dealing with ST for over a month trying to get my MMS to work on my S3. My S3 does everything I need it to and it is paid for. I was about a week away from going to TMO after 3 plus years of good service on ST. I got the same old run around from all the "tech" support clowns....after an hour or so I was advised to call Samsung because it is my phone. Honestly, after the way I yelled at some of these "techs" I am glad they cannot speak English!!! I am convinced ST must pay a lot to the carriers for MMS as they HAVE TO KNOW WHAT THE PROBLEM IS!! If I can figure it out, they know!! First of all, if you do not have the ATT LTE SIM card, go get it!! The LTE sim card will make your phone smoking fast!!! If your MMS is still not working as mine was not, do not despair my friends!! I was truly about to spend $600 for a new S5 (and I still want to if someone can tell me where I can get the 32 gig model please?) but had read that the MMS problem could be cured with a new ATT sim card, but cancel your current account with ST and start a new one with the new card. I, however, just moved my service over to the new card as I didn't want to risk the porting of my number. Still no MMS but amazing fast internet. I started playing with the APN settings and just happened to compare the original ATT setting to those provided by ST. ST is intentionally (IMHO) not telling their clients the correct APN settings!! I used what they provided but added in the correct APN type settings (this is what ST is not telling people to do). Here are the settings that are working for me today and the MMS messages are flying out:

Name: st
APN: tfdata
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: htttp ://mms-tf.net (no space, I'm a new poster)
Multimedia message proxy: mms3.tracfone.com
Multimedia message port: 80
MCC: 310
MNC: 410
Authentication type: Not set
APN Type: default,hipri,mms,supl,fota (I seriously believe this is all you need to change to make it work with the old SIM)
Keep the rest the same and good luck! And don't waste your time with the ST forum, they run you through a bunch of crap and then send a generic "Your screwed call us and waste some of your time" message...

Norm GrantAbigale TwenteN cMyaBee WellMorgan Ballardmcee

Reply
  • Forum posts: 1

Feb 22, 2015, 2:32:30 PM via Website

I just wanted to say thank you! I have a Samsung galaxy s3 through at&t and I just switched over to straight talk now that my 2 year contract is over with At&t. My picture messaging wasn't working and now it is thanks to your post. All I needed was to add to the APN type:)

Reply
  • Forum posts: 1

Mar 26, 2015, 3:12:18 PM via Website

Where do I find these settings on the phone? I am having the same issue and can not receive MMS

Reply
  • Forum posts: 5

Mar 26, 2015, 6:58:39 PM via Website

Google: how do i change the apn settings on my galaxy s3

Rose Young

Reply
  • Forum posts: 1

Apr 12, 2015, 10:52:17 PM via Website

the settings that you need go into the mauual apn configurations of youre txt messeging app

Reply
  • Forum posts: 1

Apr 13, 2015, 8:38:14 AM via Website

I haven't been able to send multimedia messages since I got my GS3 from ST a few months ago, when I goto my home page, press the menu button and go into the settings area, there is no Apn settings. Go into the more settings area under wireless & network settings there is no Apn settings for me to edit like my other st phones have had.
I'm pretty sure your post is 100% accurate I just can't figure out or find the settings area I need as easily as I have been in the past.
Please help and thank you for any help/my tech ignorance.

Reply
  • Forum posts: 5

Apr 13, 2015, 10:04:56 PM via Website

First go to your Android’s main Screen, then go to the Settings Screen

Under Wireless and Networks, please select More…

Now go to the option where it says Mobile Networks (Sometimes it might Say: Wireless Networks)
You will now See Access Point Names, Tab on it…

Now select NEW APN and Enter the APN Settings require for your carrier, Please go to the TOP menu of our website, under APN, select the country and mobile network operator you are using for the detail APN Setting on your Samsung Galaxy S3 mobile phone.

Reply
  • Forum posts: 1

May 16, 2015, 3:53:56 AM via Website

Under my Mobile network there is only Mobile data, nothing else. Could that be because mine is a straight talk phone? I have never been able to send picture text since i bought this phone. Keeps saying "invalid address".

Reply
  • Forum posts: 5

May 16, 2015, 4:50:06 AM via Website

I have never had an actual ST phone, sorry...

Reply
  • Forum posts: 2

Jun 5, 2015, 5:20:09 PM via Website

I have had Straight Talk for about 2 years ...and I noticed that the 4g is not so fast with my slightly used AT&T S5 ....I sure could use some more data bandwidth.... but can't give up my old phone number...I have to port .........Is there is there a reason why I shouldn't port my new Straight Talk SIM card?

Reply
  • Forum posts: 1

Jun 20, 2015, 7:24:31 AM via Website

strong text I just got my straight talk samsung galaxy s3 today. I cant receive MMS picture messages but I can send them. I tried looking online to fix the problem but I cant find anything. I do not have the APN setting, I only have the VPN setting. Can you help me? Thank you!

Reply
  • Forum posts: 2

Jun 21, 2015, 6:34:47 AM via Website

Show me what what your apn settings are....you might have an error or errors.

Reply
  • Forum posts: 1

Sep 10, 2015, 1:06:36 AM via Website

Hi, I have.the exact same problem. Did you ever figure.out an answer? I also have no apv just vpn and can't send picture messages.to anyone or myself.

Reply
  • Forum posts: 1

Sep 13, 2015, 5:52:33 AM via Website

The original APN settings provided in the first post by asample is what finally solved my MMS issue with Straight Talk. I already had the APN settings that they had, but had not found the APN Type details listed the way that they did. I updated that setting and my problems are solved.

Name: st
APN: tfdata
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: htttp ://mms-tf.net (no space, I'm a new poster)
Multimedia message proxy: mms3.tracfone.com
Multimedia message port: 80
MCC: 310
MNC: 410
Authentication type: Not set
APN Type: default,hipri,mms,supl,fota

Reply
  • Forum posts: 1

Sep 30, 2015, 1:53:21 AM via Website

I have an unlocked at&t galaxy 5 that I just set up with straight talk. Have been using just over a week. Everything works except mms. I tried your settings but still does not work :(

Reply
  • Forum posts: 1

Feb 29, 2016, 2:49:41 PM via Website

I still have issues....two phones with ST, an S4 and S6. All was fine until about 2 weeks ago when MMS stopped working. Fixed the settings to correct that issue, but now can not get internet without Wifi. If I fix the Wifi issue, then no MMS. What's the trick to get both working correctly again. This is very frustrating. Thanks in advance for the help!!

Reply
  • Forum posts: 1

Mar 7, 2016, 8:14:35 PM via Website

I had tried for 2 yrs to get the settings right on my husbands phone and I had done a factory reset on his phone so thought I would check the web again for correct settings for him to send and receive text pictures and Whala this was the fix! Thanks so much for this

Reply
  • Forum posts: 1

May 29, 2016, 4:06:09 PM via Website

Thank you! And yes all I changed was the APN type and it's working perfectly!

Reply
  • Forum posts: 2

Jun 15, 2016, 5:27:42 AM via Website

I have a Note 3 and have been with st for almost a year. MMS has worked fine until today. Any suggestions to fix the problem?

Reply
  • Forum posts: 2

Jun 15, 2016, 5:30:58 AM via Website

Is the information in parenthesis also to be included in the MMSC. And also for the APN type are all those nametobe entered as such or just one of them?

Reply
  • Forum posts: 1

Sep 10, 2016, 7:14:04 PM via Website

I have a galaxy s5 ,tried other apns that didn't work,this solved my problems, thx so much.

Reply
  • Forum posts: 1

Oct 24, 2016, 4:16:54 PM via Website

So i used the info that ST gave me, and it did not work, even though it does work on my friends phone and it is the same as mine. Your setting worked. Thank You so very much...
:D

Abigale Twente

Reply
  • Forum posts: 1

Dec 20, 2016, 8:51:23 PM via Website

OMG Thank you so much!!!! I have been trying to get my phone back since I had to reset it a month ago. I have visited so many sites even straight talk themselves to no avail, and a lot of frustration. Came across you on search and you made my day. The only thing I reset was the APN TYPE and as you said that was all I had to do. You are wonderful, great, and woohoo glad you posted your fix. I can now send pics of my newly fostered rats, lol bet you're happy to hear you helped for that haha. Thank you again, have a wonderful day, I know I will.

Abigale Twente

Reply
  • Forum posts: 1

Aug 11, 2017, 5:21:26 PM via Website

I just want to thank you for posting this. I have a Samsung Galaxy S5 active, just changed from ATT to Straight Talk. The APN settings gave me a headache, then I found your post.
Same thing could not send or receive pictures. It was the APN type and maybe the Multimedia message proxy. These settings work great and you are also right about straight talk they did nothing but confuse me more.

Easily confused;)

Abigale Twente

Reply
  • Forum posts: 1

Jan 8, 2018, 11:04:10 PM via Website

Thank god for your post! I have a SG NOTE 4 and I transferred my service to it on Black Friday to a new sim card. At first it all worked perfect. For 1 day! Then all service reverted back to my old sim and phone. I called straight talk and it took 2 days to get my note 4 working again. But now this time MMS dI'd not work. I was just about to give up until I tried this and IT WORKED!!! DATA , MMS, AND SERVICE ALL WORKS! And faster too!!! This has been on going since November 24th 2017. The only thing straight talk failed to do with me was give the correct APN Type. How hard is it for then to relay correct information! Seriously! If it wasn't for this post they would have lost yet another member! Thank you tremendously!!

Reply
  • Forum posts: 1

May 12, 2018, 1:55:30 AM via Website

I have tried 5 other ways per instructions from other websites but this one worked on both of my unlocked straight talk Samsung S6 Active phones. Thank you.

Reply