Samsung Galaxy S2 — USB Sticks doesn't work anymore

  • Replies:4
  • OpenNot stickiedUnanswered
  • Forum posts: 8

Jul 2, 2014, 7:29:38 AM via Website

Since rooting the telephone and installed titanium backup i read neither usb sticks nor i can connect handy to the pc as usb drive.
Before automount of usb drives intern and extern worked always. I tried also to stop usb debug mode but not change. Tried slso the app usbstick mount also without success.
Any suggestions?
So jelly besn 4.1.2 original
Galaxy s2

  • Forum posts: 445

Jul 7, 2014, 11:58:44 AM via Website

tony riccio

Scott Adam Gordon

Hey Tony,

The first thing you can do is trying to clear your cache.

Find out how here:

I have
-cache wiped
-reset to factory
But usb does not works.
Any idea?

Is it definitely an issue with your S2 and not the drivers on your PC?

What happens when you plug it in to your PC? Does it say "USB device not recognized"?

  • Forum posts: 8

Jul 7, 2014, 12:25:37 PM via Website

It s not an issue only between pc and android it happens also with pendrive connected to the handy.
I receive in android status bar the message when
Pen drive plug in
Usb connected

When i plug out
Usb disconneted

But i can not see any usb drive with filexplorer

With pc is the same.

I suppose that after rooting automount works anymore.
Is it possible to manually mount like linux
Mount -vfat.....?
Other ideas?
Why after factory reset does it not work again?

Recommended articles