Samsung Galaxy S2 — Unable to perform hard reset

  • Replies:2
  • Forum posts: 1

May 2, 2014, 1:11:14 AM via Website


My S2 froze, I took out the battery and restarted it but it kept freezing on the pin screen. I have tried both soft and hard resets but still cannot get the phone to work. When performing the hard reset, I am able to reset it, but on rebooting it freezes on the 'installing applications' screen.

Any help would be greatly appreciated!


  • Forum posts: 877

May 8, 2014, 11:12:00 AM via Website

Hi guys!

Here is the link to the Sammobile Firmwares page that John is talking about.

Ensure that you search by your model number.

Also, try this:

  • Restart phone
  • on the lock screen, instead of swiping and getting stuck in "installing applications", just drop down notifications
  • on notifications menu, tap where it should say "low on disk space". It will open "Applications" from the setting menu.
  • Uninstall some apps until you get around "250MB" from the 2GB reserved by the system (250MB was what worked for me, that's the reason of the number; I had lower than 200MB before). I tried to move apps to SD Card to no avail, that's why I uninstalled the apps.

If you have locked your phone with a pattern, when you unlock it, it will send you direct to "installing app...". Run the Task manager and from it drop down notifications then follow the rest.

Hopefully one of these answers will solve the problem!