Samsung Galaxy Tab 2 10.1 — Firmware upgrade failure

  • Replies:1
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Nov 13, 2013, 2:51:20 PM via Website

Hi All, i need desperate help, recently i "rooted" my Samsung Galaxy Tab 2 using ODIN however, i decided to return it back to it's original state again using ODIN, all was going well until it suddenly stopped
and now i get the message on my tablet:
I tried shutting the tablet down and go onto Recovery mode but it keeps booting to same screen as above. I have made several attempts to re-install the stock firmware without any success. i have also tried recovery mode in Kies but i get this message when i input my details: .

Any help would be very very much appreciated

Thank You

Tony R

  • Forum posts: 877

Nov 14, 2013, 12:03:34 PM via Website

Hey Tony!

Here is what might help you in your current situation:

Download the stock firmware for your device (GT-5110)
Unzip the stock firmware
Click on PDA and choose the file that ends with .tar.md5
Click on Phone and choose the file with the name Modem
Click on CSC and choose the file that says CSC
Click on PIT and choose the file that ends with .pit

If you only have a PDA, you can ignore the other steps.

It is super important that you only use firmware that is made for your model, since there are many versions of the Galaxy Tab 2. Your model is GT-P5110 so just find ones for this version.

Let us know if this did the trick!

Recommended by NextPit