Can I register an unknown tablet?

  • Replies:7
  • OpenNot stickiedUnanswered
  • Forum posts: 3

Oct 15, 2013, 11:26:10 AM via Website

I bought a tablet in Suning electronic chain store in Beijing 2 years ago, it cost 999 yuan, about £100 or €130. I can install some apps on it, but I don't seem to be able to do it directly from Google Play. I have to try to download the apk file & then use the apk installer. But this doesn't always work. So I'd love to know is there any way I can register my device with Google Play. It gives many tablet options, but not mine. Maybe it's a political issue, I don't know.
It's called efun M900, also called MID. (when I connect it says "You have connected your MID to your computer via USB...") It takes mini sd, also has NAND flash 2.81GB, internal storage 248MB. Last time I was on Google Play the message said "no eligible devices for app install".
"About Device" says
Model number M900
Android Version 2.3.1
Kernel version
Build number V1.0.17.GINGERBREAD.eng.root.20111014.005339_HW1.0.0.0

I also have a Sony Ericsson mini xperia, (ST15i) now running Android 4.0.4; Google Play does recognise this device.

Thank you

  • Forum posts: 1,110

Oct 17, 2013, 2:50:56 PM via Website

Hey @Richard, you hit the nail on the head. Chinese tablets are not compatible with the Play Store for political reasons. There is increasing development going on and plenty of alternatives to the Play Store, but there are quite often stolen apps on them, and lots of scams and malware, from what I've heard. Unfortunately I can't really recommend any, but there are plenty of ways to access Play Store apps. Try this YouTube tutorial and let me know if that works for you.

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

  • Forum posts: 3

Oct 22, 2013, 10:47:03 AM via Website

Kris, thanks for your input. I checked the video but have 2 issues before I proceed.
1. The link to the web site given in the text in 3a by RolandDeschain79 is different to the one shown in the video.
Clicking the link brings me to
But I don't think this is the correct one.
The link shown on the video at 1m04s is

I left a comment on youtube about this (posting as RichXZ)
I had to change references to websites in youtube comments. I don't know if there's an accepted way to do this, I just wrote "dot" for "." & youtube accepted it.
2. When I tried this the other day I was asked to register, & include credit card details, which I was reluctant to give, even though the site claimed they would not take any money unless I purchased something from them.


  • Forum posts: 1,110

Oct 22, 2013, 2:19:55 PM via Website

Hmm, good pickup Richard! I would wait for a reply from the poster of the video, and if nothing comes, you could download both files and compare them (date created, file size etc) and see if perhaps they are the same thing hosted in two different places. Then I guess you've got no option other than to hold your breath and pick one. Even if it doesn't work (scan it first) then you can just uninstall it and try the other one. But do a complete backup before you start, just in case, and run an antivirus first before running either one, just to be sure.

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

  • Forum posts: 3

Oct 22, 2013, 4:32:04 PM via Website

Ok, Kris, thanks. here's how things stand at present

The first website invites me to download This may be another name for Google Play store (I don't know), but I didn't download it.

The invites me to download Play Store

3.10.14.apk , which looks right

But when I click (using my tablet) it either offers a download of TorchSetup.pkg or invites me to sign

up with (depending which download button I click).

Then I have to register with email address & password, (I did this) which then brings me to a page

where I can upload files, but I can't see a way to download anything!

The FAQ said go to My Files, but I tried that & couldn't see anything. So instead I went to on my PC, & successfully (surprise)
managed to download Play Store 3.10.14.apk, then copied it to the tablet.

This seemed to work. I now have an app on my tablet home page (is it called the
desktop?) called Play Store, with the same icon my phone has for Play Store. But when
I open the app, it says "You must add an account to the device to continue. Do you want
to add one now?" I click "Yes", but then the app just switches off. ("No" produces the same
result). I do have an email account with Google registered on the tablet. I switched off & on
again, but it's still the same.

So I'm not really sure if that's progress, but it did take time!


  • Forum posts: 1,110

Nov 27, 2013, 2:56:29 PM via Website

Hi @Richard, sorry I missed your reply to this thread. Glad you managed to get the APK installed but I'm not entirely sure why it is crashing? You can install the latest version of the Play Store from an article I wrote recently here. If you haven't managed to get the one you downloaded already working, try this new APK and let me know how it goes.

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

  • Forum posts: 6

Nov 28, 2013, 1:48:52 AM via App

there are so many answers about this google play problem in china forums. i suggest that you should look for the resolution in china forums

  • Forum posts: 14

Dec 12, 2014, 1:28:44 AM via Website

Indeed, for China tablets, a rooting prior to downloading/installation is of big help.

Recommended by NextPit