Hard Reset your Google Nexus 7 (2012)

  • Replies:11
  • Stickied
Kris Carlon
  • Forum posts: 1,110

Aug 13, 2013, 6:44:12 PM via Website

Performing a Hard Reset on your device is simple as pie. The difference between a Factory Reset and a Hard Reset is:

Factory Reset
The 'lighter' of the two reset options. It can be done either in settings or via recovery menu. It wipes all user data and firmware settings but leaves the contents of your internal SD Card intact.

Hard Reset
Restores a tabletto its basic factory settings, which erases all applications that were installed by the user as well as all user data. Hard Reset wipes everything including the contents of your internal SD Card. Whatever firmware you last flashed will be the firmware you get back, but everything else will be wiped.

Have you already tried to Factory Reset first? If not, the tutorial is here. If this hasn't solved the problem, let's proceed with the Hard Reset for the Google Nexus 7 (2012).

  • Turn your tablet off.
  • With the tablet off, press and hold the Power key, then press and hold the Volume Down key. Scroll down twice to select Recovery.
  • Select with the power key.
  • You'll see the Android pop up, then while holding down Power, press Volume Up.
  • Use the volume keys to scroll to "Wipe Data/Factory Reset" and press Power to select it.
  • Scroll down to "Yes - Erase All User Data" and press Power to select it.
  • Your Hard Reset is now complete.
Let us know if you have any questions or problems.

— modified on Aug 13, 2013, 6:45:46 PM

Follow Kris on Google+ and Twitter / Forum Rules - Recommended for new AndroidPIT members! / Important to all community members: please read before posting

Scott Bloxom
  • Forum posts: 3

Dec 9, 2014, 6:05:04 PM via Website

Nexus 7 2012, after the Android 5.0 L upgrade, tablet stuck in a boot loop.
Shows Google logo at start-up, the the 'flying colours' gets to the lock screen, and reboots.
Factory Reset / Hard reset both are not doing anything.

This is a stock Nexus 7 2012, not rooted or running any other mods.
Android 5.0 OTA install.

Help please, or do I now have a paper weight?

user ID: 6903258

— modified on Dec 9, 2014, 6:12:19 PM

Scott Bloxom
  • Forum posts: 3

Dec 24, 2014, 7:27:07 PM via Website

Tried to use the SKIPSOFT ANDROID TOOLKIT, device will not stay on long enough to be recognized by the PC.
Thank you Google for bricking my device...

So mad that there is no fix for this!

Mark James
  • Forum posts: 1

Dec 25, 2014, 7:27:45 PM via Website

Same here. Very useful paper weight completely useless tablet.
Stuck in reboot cycle. Tried all the software and actions I could find. Unfortunately nothing will unlock boot loader.

Scott Bloxom
  • Forum posts: 3

Jan 19, 2015, 4:29:16 PM via Website

Mark, same here...
Very frustrated...I emailed Google, no response.
(Not surprised!)

Will not upgrade another device to 5.0
My Nexus 5 went through battery in less than 8 hours, until the 5.0.1 update came out...now back to normal.

Who does the testing at Google?... [Apple technicians?]

Manuel Robles
  • Forum posts: 1

Jan 24, 2015, 9:24:03 PM via Website

I tried this option and my Nexus table is still stuck on the starting screen with the colors rolling in circles.
I have chosen the wipe cache partition
I have chosen the data/factory reset
and the reboot system and I end up back that the rolling colors at the start screen after the Google sign passes.

Any other ideas? I was on a Google support site and several people on that site were given the option to send their Nexus 7 tablets In and received replacements. I haven't asked Google if that's an option for me, purchased my Nexus 7 tablet at an electronics stores not Google direct.

I would really appreciate some help getting this Nexus pad up and running.

Thank you,
Manuel Robles

al lin
  • Forum posts: 1

Jan 24, 2015, 10:25:31 PM via Website

Tried the factory reset (erase data) and it worked!! Stock Nexus 7 (2012) not rooted.

After all data reset, 5.0.2 still remains and start working. All my apps and data automatically reloaded (ota). :)

Terri hanks
  • Forum posts: 1

Jan 26, 2015, 8:08:24 PM via Website

Also stuck in boot loader mode since none of the options work. Can't restart boot loader or recovery. Back to the circles..in color.. Then small white ones. Then nothing. Anyone find solution as I foolishly bought two of these. Any luck anyone, with replacement.? Worth a try to call I guess but feel they will fall back on the over a year thing. Please post any positive resolutions

heidi lewis
  • Forum posts: 1

Apr 18, 2015, 5:05:35 PM via Website

Really hope someone can help......!

Have had to do hard reset follow multiple downloads (for the same apps, over and over, several times a day - possibly due to device never staying on long enough to complete downloads???) and poor battery life. Situation got so poor that factory reset wasn't possible as device wouldn't stay on long enough even when connected to mains supply.

Got into the options easily enough and began process...got the android with his tummy open and 'erasing' blinking underneath......but after several minutes of this (15-20 has been the longest), device freezes, and the android on his back with red triangle appears. And he stays like that until I double press the buttons....and the google logo comes on - and then back to the android with his tummy open and 'erasing' blinking underneath...and the whole process starts again.

Have tried to connect device via usb to laptop...it isn't recognised. Have downloaded relevant driver...but that doesn't seem to want to work either.....

not sure what else to do now!

Mary Alletto
  • Forum posts: 1

Feb 28, 2016, 1:45:03 AM via Website

My Nexus 7 tablet 2012 will not erase anything at all. After I hard reset in recovery mode and reboot, it still retain all apps and info. I don't know what else to do. I can turn off power then when I turn it back on it keep cycling.

John Furystrom
  • Forum posts: 47

Jul 14, 2017, 3:27:06 PM via Website

easier to flash other ROM (preferably to flash older versions of android)

  • Forum posts: 1

Mar 8, 2020, 8:29:54 AM via Website

Nexus 7 (2012) HiFi tablet issue
At startup the tablet locks and shows the colored X sign.I press the Sound Down + Power keys and train in Bootloade and then in Recovery Mode. Unfortunately I do not have a custom Recovery installed, so I press the Sound Up + Power keys to enter Android System Recovery. I choose the Wipe data / Factory reset option and I choose the Delete all user data option. After a while I get the message that the data has been deleted and returned to the factory settings.
I restart the tablet and the result is the same: it freezes in the phase that appears in the first image.
How can I fix this problem since I can't access the tablet settings to check USB Debugghing and I don't have a Recovery custom installed on it.
I mention that:
1. The battery is good, it charges and it lasts quite a long time (about 10 hours).
2. The Windows 10 laptop does not recognize the tablet and does not install the appropriate drivers.
3. I installed Universal ADB Driver on the laptop and it was still not seen by the adb devices command.
4. I still have a tablet identical to this one that works flawlessly. Can I use a backup of this tablet to repair the damaged one?