Nokia X — Wifi problem - 'On' but no wifi icon and not working

  • Replies:3
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jan 11, 2013, 12:02:25 PM via Website

Hello all,

I have a Philips W626 (an unusual brand/model I know) and have recently got a problem with the wifi on this phone. It was working fine before.

The phone is rooted.

The wifi is on according to the phone, it displays available connections but won't connect. The wifi status remains on 'scanning' even though there are lots of connections available (which I've conncted to previously) and then 'disconnected'. When I try and connect, it just says, 'connecting...authenticating...disconnected'. One connection says 'Disabled' but I can connect to it on my laptop just fine.

Even though when I go into settings it says wifi is enabled, no 'wifi icon' appears in the status bar.

Tethering doesn't seem to give me internet access either.

I'd really appreciate your help.

  • Forum posts: 1

Jul 14, 2013, 12:13:44 AM via Website

This is what i did and it worked for me:

GO to your android phone wifi settings..turn on the wifi...make sure u entered the pin and it is authenticated and saved...wifi icon not appearing in top status bar at this time
so once u go to andrid on the options/menu let touch screen button on my phone and then it will give u an option to add WPS PIN

click on it and it will generate a PIn and ask u to enter it in the router

i have a netgear router so i opened my laptop internet explrer..entered netgear URL and on left menu i cicked on "Add WPS Client" and entered the PIN generated on android phone by selecting that option.. once u enter the pin..look at ur phone and it will refresh and the wifi icon will appear

  • Forum posts: 1

Nov 14, 2018, 2:43:42 PM via Website

Even i have faced the same Issue recently. My Mobile is connected to the WiFi, But still my Internet doesn't Work. I tried Unplugging the WiFi Connection and reconnected it. No use. Then i Did one thing.

I simply Restore Factory Settings of my router using IP. Most of the times, or the Gateway IP Address of a WiFi Router. Now once check if everything is fine or not. :)

  • Forum posts: 1

Oct 15, 2019, 8:24:41 AM via Website

I have been using a Nokia X since 2014 and am still using it. I have been having a similar issue. I recently discovered that for public wifi, the login prompt doesn't show. Steps to resolve it:

  1. Turn on public wifi.
  2. If login prompt doesn't appear, then just go to Opera, type and the login prompt shows up.
  3. Click connect on the prompt window
  4. Voila! you're connected.

As for Philipps, I am not sure, maybe a similar "captive" page (perhaps the Philipps website) will help resolve it. I also had the same issue with Mac - and recently discovered I just had to type

Recommended by NextPit