Can't get into Recovery mode

  • Replies:2
  • OpenNot stickiedUnanswered
  • Forum posts: 1

May 9, 2012, 6:38:51 PM via Website

Hi to all people, i would like to root my phone but in order to do that i need my phone to get into Recovery mode, that is the part where i fail, could you guys help me?

I have a Samsung galaxy s plus and i have a problem.

I cant seem to get into recoverymode. I tried all the key-combinations, such as: Volume up and power; Volume up, down and power; Home, volume up and power... etc. Pretty much any combination.

With the Home-VolumeUp-Power combination i got into RAMDUMP MODE. I had no clue what that was all about so i took out the battery.

With the VolumeUp-Power combination and a right timing i got to the 'Android out of the box'-screen (below). After 10 to 20 seconds that screen disappeared and the phone rebooted again.

I was looking on google and they were talking about the ADB mode. So i tried that one an that gave me the same result as the VolumeUp-Power comination.

I also tried the ROM manager app but because my phone is not rooted this was no option either.

I think my phone is blocked from the recovery mode.

Cold you please help me, and excuse my grammar, im Dutch.

Im a total noob so please, try to explain in simple English.

— modified on May 9, 2012, 6:41:03 PM

  • Forum posts: 610

May 10, 2012, 11:42:37 AM via Website

I'm not 100% sure, but i do know that samsung and some carriers removed recovery in certain European countries, so check with your network first. If it isn't disabled then you'll have to do a factory reset.


  • Forum posts: 1,811

May 14, 2012, 5:58:44 PM via Website

Are you trying to reach stock recovery mode? Im assuming you want to root your phone right?