Android Forum – Reply to "Android 6 needed for sm-t585"

You must be logged in or registered to write a forum post.

Please log in at the top of the page!