Unpacking-repacking the stock, unmodified, system.img (Nougat) leads to unbootable device.

  • Replies:0
  • Forum posts: 1

Sep 17, 2018, 9:08:40 PM via Website

Hello everyone!

I ask for your help regarding unpacking-repacking system.img of an Android 7.0 Nougat.
In order to start a porting process, I have just tested several system.img tools (for unpacking-repacking it).
I have tried with the stock ROM (for testing purposes). Just unpacking-repacking the original ROM. But the system is unbootable, after flashing the new image.

What I did:
- From boot.img/ramdisk/fstab I have deleted the "verify" tag from /system partition ---> which should have disabled the dm-verity
- I have unlocked the bootloader (via fastboot oem unlock). It is confirmed at Logo stage.
- From boot.img/ramdisk/default.prop I have set the ro.secure to 0 (from 1), ro.adb.secure to 0 (from 1)

What tools I have tried:
- All Windows tools found on the Internet for packing-repacking system.img
- Under Linux, simg2img and img2simg, etc.etc.

- EVERY time, the system.img file resulted is smaller (with several MB!!) than the original one! Without any modds!
- System unbootable. (after flashing via SPFT)

The problem is 99% with the image tool, because the output is smaller in size than the stock ROM.

They are not relevant, but I provide some information about the device.
- MT6753 chipset
- Device: VOYO Q101, 2GB/32GB
- Android Nougat 7.0, kernel 3.18.35+

PS. Unpacking-repacking a 5.1 Lollipop is okay. The repacked image has the SAME size as the original one. Unfortunately, something happens with Nougat images and ALL extracting tools.

Any ideas? Thanks!

Be the first to answer