How can i unbrick my Asus ZenFone 5?

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Mar 30, 2016, 1:42:00 PM via Website

Hi everyone, i know this post may be long... but i really beg you to read all the steps, because i have a common problem but the fixes i found in the forum didn't work for me: my ZenFone 5 stucks at "Asus" logo with a loading loop wheel below that.

1) Phone stucks at logo, but could enter recovery (pressing vol + down), i've updated it via external SD card (official firmware but didn't work) then i've wiped data and did a factory reset. Phone still stucks at logo.
2) Now i can't even enter recovery mode... when pressing vol + down it shows 2 options but whatever i choose the phone reboots. If i press vol + up it says "CSC mode, long press power to restart. Phone still stucks.
3) Now (after some time) the phone's screen doesn't show anything, nor charging icon or notification led when recharging, but strangely the computer recognizes it as a device when connected via USB cable, and the led turns on when i do this.

A friend told me to follow a guide that says to install "Intel Soc USB driver", i did that. After installing, when connecting the device, 2 things should pop up in Device Manager, under "Intel Soc": "Cloverview Plus Device" and "Intel Soc USB Driver" but they don't show to me

I've also tried Asus flashtool guide... at step 4 it says to click in the box icon and choose the firmware RAW file, so i've downloaded a raw firmware for the ZenFone 5, but oddly it doesn't let me choose any raw file.

Note: the phone is recognized by the pc as "QHSUSB_BULK", so i've tried to update its driver with qualcomm drivers, and now it's recognized as "Qualcom MMC Usb storage device". But i think i've did a wrong thing cause my friend told me i should have choosed some kind of official driver

Thanks in advance for your help

— modified on Mar 30, 2016, 1:42:15 PM

Recommended by NextPit