Sony Xperia Z — Google device finder and block function

  • Replies:0
  • Forum posts: 3

Jan 9, 2016, 6:27:53 PM via Website

My daughter lost her phone last week. As soon as she realised it was lost she went online to see if she could find its location at google android device manager. It had been switched off so she pressed block and gave it a password. She also blocked the sim card and ordered a replacement with the same number.

Today she got the phone back (someone found it) but the new sim card isn't working even though she's unblocked the device with the password from the google page. She can go online on wifi but no network. Tried the sim from my phone and it worked, tried her new sim in my phone and it worked.

Do you know why, even though she has the correct the password, she can't use her network? Can you not remove the 'block' that she put on the day it was lost? She went on the provider website (O2) and blocked the sim card and straight away ordered a replacement. It came today, she activated it online and when it didn't work in her phone after an hour we tried it in mine and it worked. We don't understand why she can get onto the phone with the password but not use the sim card.

— modified on Jan 9, 2016, 6:28:19 PM by moderator