Samsung Galaxy S4 — Can't connect USB Galaxy S4 to PC

  • Replies:3
  • OpenNot stickiedAnswered
  • Forum posts: 6

Jan 3, 2016, 4:18:06 AM via Website


I have tried to connect my phone to several PCs with several cables but still no good.

In Settings the USB tether is grayed out so I can't it.

It shows it is powering on the USB but cannot see it in the PC tree explorer.

Any help please..


  • Forum posts: 583

Jan 3, 2016, 1:16:48 PM via Website

First lets start with question, When you connect to PC does your phone start to charge? If yes, then it might be the driver, if not then the problem can be either the cable or the port.

Looking for security app? Try Leo Privacy Guard 3.0.

Join Our Christmas Contest by visiting our Facebook page "LEO Privacy Guard"


  • Forum posts: 6

Jan 3, 2016, 11:43:59 PM via Website

Thanks for the reply.

Yes most tikes it shows it is powering up.

I tried many cables with same result . zip !

I eventually started form scratch .. Turned both phone and laptop off then on.

Uninstalled 'Unknown USB' from Device Manager in Win 7.

Eevntually was able to choose between 'Camera and MTP' Chose MTP.

It then showed in the Explorer tree.

I was able to then copy all data from phone and card.

I still am not 100% sure why it worked because I tried so many thins. I think turning all off and on again may have reset drivers etc.


  • Forum posts: 1,319

Jan 4, 2016, 2:26:22 AM via Website

I had problems some like these when I first had my Note 3 connecting with notebook (Win 7). I am also not 100% sure why it worked after I tried many times. :(

Download size < 0.07 MB. But also Accurate, Ad-Free & Full-Free.
The minimalist app available on Google Play
Your 5-star is appreciated. Blog :


Recommended by NextPit