Samsung Galaxy S3 — Rooted Android won't show widgets

  • Replies:0
  • Forum posts: 1

Nov 3, 2015, 9:40:41 PM via Website

I rooted my Galaxy Light (T-399) using Odin and TWRP. I wanted to start fresh so I reset the
whole thing and reinstalled only the apps I plan on using. My phone had previously slowed down
quite a bit and I figured, "Hey, when this happens with my computer a fresh install of Windows
seems to help." And clearing up the phone really has helped.

I downloaded what I needed,
I turned off some of the stock features - not using any third party software, I did it straight
from the stock App Manager.
I did not move any stock apps to the SD card (I have moved some of the downloaded apps to the
SD card but I don't believe I moved anything that didn't originally come with the option to
move them using anything but the App Manager),
I have not installed any root ROMs through Xposed yet,
I have only installed Greenify, Link2SD, Intelli3g app, Airdroid, NoBloat, PC Remote, Quick
Settings, and Roundr..

I HAVE installed my normal non-root needing apps. I got them directly from the playstore
again - I didn't save any of the apks to my SD card or anything and install them from there.
I am running Jellybean - which is as high an OS as my phone will go or can handle (I think - if
I'm wrong please lemme know, but I also don't know how to update the OS once my phone has been

Now I am missing widgets. Not only do they not show up when I drag them to the home screen
from the Add Apps or Widgets menu, but some of the ones I previously had on my homescreen have
disappeared and aren't even in the menu to re-add them!
This was happening before I reset my phone, and the rest did not fix it (obviously) - prior to
the reset I also did a restore using TWRP. Yes, my phone is still rooted and SuperSU is giving
things privileges with no problem.

Could someone please help me figure this out? I have read a few forum posts with people who
have similar problems. I have tried restarted my phone. I cannot move the apps back to the
internal memory as a fix because some of the ones having problems were never moved to the SD
card in the first place. I did not put my SD card into the phone until after I had reset it
and formatted the SD card.

Please help! I don't particularly mind having to do another reset but it would be kind of a
pain and didn't fix the problem in the first place so I don't really see why I should. I need
ideas, mostly to get my e-mail app K@ mail) to show the widget. Notifications for it were
never turned off and it was never moved to the SD card.

Speaking of the SD card, it appears to have write problems when it is in the phone (I can't
move media to it using my computer even when debugging mode is on). I can, however, write to
it when I pop it into my card reader in my Acer or my usb card-reader/adapter using my Compaq.
I hope I have given all needed information to get some help with this. If I have not, please
let me know what YOU need to know. =)

I am planning on getting a new phone next week, but this is what I consider to be my
experimental phone given that it is so old and will be replaced (I don't want to root the new
one when I get it until I have worked out all the kinks).

I'm a bit frustrated. And, if you have time, please read my other posts regarding computer
issues I have run into just to see if you can help. I have found that I get myself into the
weirdest situations...