Samsung Galaxy A5 echo

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Oct 21, 2015, 1:15:33 PM via Website

Hi everybody!
My problem is that when somebody call me on my Galaxy A5 they hear the echo sound.
I turned off the Talkback and noise filtering but the problem is the same.
Is there any solution to solve the problem?
Thank you,

Recommended by NextPit