Samsung Galaxy S4 — Rooted and now I have no wifi

  • Replies:3
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Mar 7, 2015, 1:07:49 PM via Website

Yesterday, I decided to try my hand at Rooting my 3 yr old Verizon Galaxy S4, running 4.4.2 kitkat. I used Towel Root and Superuser app. Then all of the sudden it started rebooting itself over and over and over. I read for a bit and found that this is bc I tripped the Knox security features. I was able to work around that by using the superuser app to disable knox. Then I realized that I no longer have WIFI. I can see the toggle, but when you tap on the toggle or try to switch it to on, it reverts directly back to off. At first it was a very light green as if on, but then turned grey and stayed that way.

I did a little more research and found that folks had issue with Wifi not working so they did a master reset to factory settings. I did the same and it still doesn't work.

I have been doing research on Unroot but have not be able to figure it out. I am a novice at this so....

Any Ideas?

  • Admin
  • Forum posts: 2,323

Mar 7, 2015, 1:34:59 PM via Website

Well, you can unroot your device is by flashing the stock ROM back again to your S4 !!

Steps to Unroot S4:

Step:1 Download the official firmware for your device from the Sammobile Firmware Section (Make sure you get the appropriate stock firmware)

Step2: Download the latest version of ODIN and unzip the ODIN to get .exe file and run it as an administrator.

Step3: Now you need to put your device onto the download mode by pressing Volume Down + Power + Home button.

Step4: Once its in download mode connect your device to the PC/Laptop with the help of USB cable and wait for the ODIN to recognize.

Step5: Click the AP button and locate the tar.md5 file in the zip package (The stock ROM file which we have downloaded in Step1) and hit Start.

Step6: Make sure re-partition box is not checked, Auto Reboot and F.Reset time is checked and hit the start button.

Step7: After hitting the start button wait for a while for the flashing process to complete, and upon completion your device will reboot automatically. (In the top box of ODIN a green light will glow while saying PASS)

Step8: Once the device reboots, you can disconnect the USB cable and can start using it !!!

See if that helps you out with the problem you are encountering !!!! :)

Also if you have problems at startup, you can perform a wipe data/factory reset in recovery mode i.e. rebooting the device by pressing Volume Up + Power + Home button.

Let me know if you encounter any difficulties !!! :)

*Note: Before proceeding make sure you have made backup your data as this process is going to wipe out the all of your data. *

— modified on Mar 7, 2015, 1:36:31 PM

  • Forum posts: 15

Mar 21, 2015, 4:28:18 AM via Website

I've been rooting and messing around with Androids since I had an HTC EVO. It was a great phone and uper easy to do whatever you wanted, to the point that
i bricked it twice, and i was able to recover easy as hell.

I've been dealing with my SPH-L720T SGS4, and it was doing fine, until last night when I tried to flash the SUPER S4 DEODEXED ROM and it all went downhill from there.

Ever since I flash CWM few months ago, I haven't been able to reflash back to stock or install any other recovery like TWRP or nothing and I know it has to do with this:

When I place the phone on Download mode, this is what the top left corner says;


Any information will be highly appreciated.

Thanks for your time

  • Forum posts: 1

Apr 23, 2015, 3:30:20 AM via Website

Did you flash the latest modem after you flashed you rooted or flashed a new rom? Might want to try that.

Recommended by NextPit