Motorola Xoom — Mobile data seems to be connected but doesn't work

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 1

Jan 11, 2014, 6:50:01 PM via Website

Hello, I am encounting a mysterious problem:


Sometimes, the mobile data connection seems to be connected (the arrows are coloured) but the connection doesn't work.
I can't find a rule about a specific factor that causes this malfunction.


I tried to solve the problem by:
  • disabling and re-enabling data connection
  • enabling and re-disabling flight mode
  • using some applications from google play which promises to fix data connection issues
  • cache cleaning
  • ram cleaning

However, I discovered another solution that permanently solves the problem for specific apps:
  1. When the problem occurs, I open an application that needs internet connection.
  2. I test data internet connection through this application to be ensured that it doesn't work.
  3. I disable data connection, enable wifi and test if the application now has internet connection through wifi.
  4. I disable wifi connection, re-enable data connection and test again if the application now has internet connection through data connection.
  5. Data connection now works normally only for the specific application but not for other applications. Doing the same steps for another application the problem can be also solved for the other specific application.

After these attempts I wonder:

Which factor causes the problem?
What exactly a reboot achieves that solves the malfunction?
How can I solve the problem by acting similarly to a reboot but without rebooting the device?

Any ideas??

Device: Motorola Atrix 4G
Custom Rom: Android 2.3.7 Cyanogenmod MROM -1-0.20130113-olympus[/URL]

— modified on Jan 11, 2014, 6:52:53 PM

Recommended by NextPit