Can anyone help me (F180L)

  • Replies:1
  • Forum posts: 1

Oct 21, 2013, 11:05:34 PM via Website

My phone LG Optimus G (F180L) is rooted and unfortunately i unistalled the applications Google Play tv and Play movie. WiFi is on and a message comes that software update is available. I allow to update. When the update finished, my phone reboots and stuck on LG logo.

Now TWRP installed together with LGNPST TeenyBin

From the fastboot screen, it shows

HW VERSION rev_11 (&¤)
SIGNING production

I could access the TWRP built in.

4) Then I used ADB to push ROM to the internal SDCARD and recovery to install. But this method failed – tried several ROMs which all gave errors initially. I discovered that the install script pointed at “e975” in(ro.product.device and but the phone reports “geehrc4g”

This is the output in recovery.log when trying to flash ROM

Warning: No file_contexts
script aborted: assert failed: getprop("ro.product.device") == "e975" || getprop("") == "e975"
assert failed: getprop("ro.product.device") == "e975" || getprop("") == "e975"

Following the advice(from internet) of changing the script by Deleting the ‘assert’ line in the script, then

E:Zip signature verification failed: 1
Error flashing zip '/sdcard/'
Updating partition details...

To ensure working environment I tried to flash gapps which worked perfectly so connection and recovery must be functional.

5) Now turning to: ”[GUIDE] How to UNBRICK your Optimus G - security error, bootloop etc”

I used the method described and downloaded the appropriate KDZ file etc. etc but flashing gives this log:

10:05:58 : Launching SW update
10:05:58 : Unpacking KDZ
10:06:05 : KDZ file extracted
10:06:13 : Files were extracted.
10:06:13 : LGMobileDL Load.
10:06:13 : Port = -1
10:06:13 : Connecting to phone
10:06:25 : Check Phone mode = 2
10:06:25 : Phone type check.......
10:06:26 : LGMobileDL.DLL Loading....
10:06:26 : _SetAuthMark Fail
10:06:26 : _SetAuthMark Ok : wAuthMark(65535)
10:06:26 : _DetachDLL Call
10:06:26 : _DetachDLL Call End
10:06:26 : ParamPhone\E97510
10:06:26 : Param : waitTime = 0
10:06:26 : Param : UsbHighSpeed = 1
10:06:26 : Param : PhoneMode = 2
10:06:26 : Param : BinVersion = E97510D_00
10:06:26 : Param : AuthMark = 65535
10:06:26 : Call fn_StartUpgrade
10:09:27 : 3GQCT : wParam = 100, lParam = 210
10:09:27 : Step : Upgrade Error error code = 210
10:09:27 : ResetStartInfo() Call
10:09:27 : _DetachDLL Call
10:09:27 : _DetachDLL Call End
10:09:27 : FreeLibrary Call
10:09:27 : FreeLibrary Call End
10:09:27 : ResetStartInfo() Call End
10:09:29 : ===FINISHED===

At the point where KDZ file is extracted the phone reverts from download mode to recovery which is probably why it fails.

I read the thread at xdadeveloper forum "[Q] Unbricking LG Optimus G e975 - using LGNPST, TWRP, ADB". Do all the things suugested but nothing happens.

I tried every method both on Win 7& XP but same error.Results are attached (see attachment)

During flashing it goes from download mode into fast boot screen and in device manager,Other devices: "Android?" is shown. When i try to install the drivers, it only picks the Google nexus 4 drivers and show the device "Nexus 4 bootloader interface".

I am so worried because i buy the phone two months ago. I cannot afford .What is happening?

1) In recovery mode it shows that it it is a MAKO product. What is this mean because every thing i know is that it is a LG Optimus G F180L and after searching Google, i find that MAKO is a Nexus 4.

2) Is TeenyBin and LGPNST creates problem? If yes, what to do?

3) I find a link which tells "how to convert Optimus G into Nexus 4". It also gives the method to convert back into Optimus G from Nexus 4 but that was a file for E970 while my phone is F180L (Equivalent: E973, E971).

How can i solve this problem? Please help me and reply me. I tried every method suggested on internet.

Bret Muller
  • Forum posts: 1

Nov 4, 2013, 12:31:36 AM via Website

So from what you are saying is that you can still get into twrp or at least download mode.... However the geehrc4g is the correct product or modified signature of the Mako model E-970 975 or F180L first try ADB pushing the newest version of TRWP the md5 is 63cb62f3df8537622b6da154e3451f54
Or the Geehrc4g img recovery zip and then flash your desired rom