Motorola RAZR i — Connection problem

  • Replies:6
  • Forum posts: 5

Mar 4, 2016, 7:47:53 PM via Website

First of all, the app cannot sent or receive messages so I tried to uninstall/install whatsapp to work that out but it is still not working. Apparently is something in my device that makes this app unavailable to connect to internet (specially in this step).
This is what is happening to me: when I tried to set up whatsapp again, after install, I can set and receive de confirmation code correctly (so there's no problem with the connection), but when I try to get the messages backup, appears that problem.


My Wi-Fi and mobile data IS WORKING CORRECTLY.

Please, I need a solution.

I attached some information

--Support Info--
Debug info: unregistered
Description: 2.12.500
Version: 2.12.500
Carrier: Claro AR
Manufacturer: motorola
Model: XT890
OS: 4.4.2
Product: XT890_rteu
Device: smi
Build: KIA20.74
Kernel: 3.0.34+ #1 SMP PREEMPT Tue Jan 6 13:08:54 CST 2015
Phone Type: G.S.M.
Network Type: U.M.T.S.
Sim: 5
L Distance: 10

  • Forum posts: 38

Mar 5, 2016, 2:22:36 PM via Website

I'm not sure if this will help, but it did for me, I exited out of the app, turned off my wifi and tried connecting through my data connection, if that still doesn't work go into your WiFi settings press on your connection and when the menu comes up press forget. Close out your settings and power off your phone, reboot your wifi, wait about a minute before turning both back on. Once you turn your router back on, turn your phone back on and go into settings, connections, wifi, select your wifi enter your credentials and then connect. Then try what's app again. Thank you, have a great day, and hope this helps. It did for me.

  • Forum posts: 1

Mar 5, 2016, 5:33:00 PM via Website

Hey, even i am facing the same problem for the past two days on my MotoRAZR xt890i, tried all reset options, re-installing, everything, except changing my phone:D, does anyone have any solution?

  • Forum posts: 5

Mar 5, 2016, 7:48:28 PM via Website

I could solve this by downloading an old version of WhatsApp (I'm using 2.12.451). The only problem is that you have to put off the update everytime you go to the app.
We'll have to wait until WhatsApp releases a version that our smartphones can use.

  • Forum posts: 38

Mar 6, 2016, 6:24:41 AM via Website

After doing a little research on this issue, what you might want to check to see if you have any task killing apps interfering with it, make sure you have your WhatsApp on approved or ignore list, and one other thing, try clearing the apps cache... Hope e this helps

  • Forum posts: 5

Mar 6, 2016, 6:28:18 AM via Website

Thanks for that! But I don't have any task killer. I did a hard reset of my cell phone, so all of that problems must have been solved but didn't. It's something in the app that is making this happen.

  • Forum posts: 10

Mar 7, 2016, 6:58:19 AM via Website

I would suggest you to do the basic troubleshooting. Hard and soft reset if necessary if its working.