Device Not Getting Detected in Eclipse

  • Replies:0
  • OpenNot stickiedUnanswered
  • Forum posts: 2

Nov 21, 2014, 4:09:17 PM via Website


I am new to Android Development. I am trying to follow the tutorial at

In the new android application dialogue, i have given Minimum SDK as API 8: Android 2.2 Froyo, Target SDK and Compile with as API:21 Android 4.x(L Preview). I

connected my Device (Moto G 2nd Edition, with Android 4.4.4) and turned on USB Debugging under developer options.

But when I run my application, Android Device Chooser Dialoge does not list my device. I have also tried adb kill-server, adb start-server and adb devices command

from platform-tools. Device not listed there also.

Thinking it might have got something to do with the Target and Compile API versions that I have choosen, I have recreated the project with API:20 Android 4.4 KitKat

wear for both Target and Compile, but then I am getting an errors like below in the debug window when the project runs.
"MyFirstApp] D:\Work\AndroidDev\EclipseWorkspace\appcompat_v7\res\values-v21\styles_base.xml:75: error: Error retrieving parent for item: No resource found that

matches the given name 'android:Widget.Material.ActionButton'."

Looking for some clues on what could get my device detected.


Recommended articles